[nSLUG] Reply Re: Problem connecting new installation Firefox to BellAliant FibreOp

Frank Geitzler frank.geitzler at ns.sympatico.ca
Fri Aug 11 13:41:19 ADT 2017

Joel, thanks very much for your help.  I have finally managed to get 
both Firefox and my system software installation applications to work 
properly.  I have provided the details here, for other NSLUG and HCC 
members, in case they should encounter a similar problem.

My Firefox Connection settings said to 'Use system proxy settings'.  I 
changed it to 'No proxy', but achieved no change in performance.  System 
Settings > Network > Network proxy > proxy method is 'None'.  the result 
continued to be 'Problem loading page' and "Server not found - Firefox 
can't find the server at start.ubuntu.com.  When I changed the target 
website to "http://www.bellaliant.net" the responses were the same; 
replacing 'start.ubuntu.com' with 'www.bellaliant.net'.

I checked back, and noticed that the 'System Settings... > proxy method' 
had an option for the Proxy Method to 'Apply system wide'.  I selected 
that option, with my master-password, and restarted the system to ensure 
that the change would take effect. I then successfully executed the 
terminal commands:

     sudo apt-get update
     sudo apt-get install synaptic
     sudo apt-get install traceroute


     sudo apt-get install ifconfig


     "E: Unable to locate package ifconfig"

As a matter of interest, I opened Synaptic, and did a search for 
'ifconfig'.  Synaptic did not find ifconfig, but returned a list of 
almost a dozen network tools, and advised that iproute2 version 
4.9.0-1ubuntu1 (networking and traffic controls) is installed. However,t 
when I entered the terminal command 'man iproute2' I was advised that 
there is no manual entry for iproute2.  Since my problem is resolved, 
however, I won't worry about that right now.

After all that, however, when I tried Firefox again, the google search 
page came up, and when I queried "How can I obtain a free copy of 
Windows 10" I obtained a list of sources -I responded to "All the Ways 
You Can Still Upgrade to Windows 10 For Free" (although it is dated 
September 22, 2016), and was able to download an image of Windows 10, 
which I plan to install in a VirtualBox.  I don't plan to use Win10 for 
production, but several friends and relatives have encountered problems 
recently with which I was only able to provide limited help -having it 
available on my own test system will expand my capability to help others 
-although I will certainly not claim to be an expert.j

Thanks again for *your *assistance with this strange problem.
Frank Geitzler

On 2017-08-10 04:51 PM, Joel Maxuel wrote:
> Hi Frank,
> Ping was successful anyway.  Getting safe for me to blame the browser, 
> unless your router has some weird port forwarding rules or something.  
> The screenshot you can check for network proxy to make sure none is 
> there.  Likewise in Firefox, ensure that Edit > Preferences, Advanced 
> > Network > Settings... has proxy set to none.  It is rare that 
> proxies are required.
> For Synaptic, I forget what the difference is between apt and 
> apt-get.  You may want to try:
> |sudo apt-get update sudo apt-get install synaptic|
> --
> Cheers,
> Joel Maxuel
> "One should strive to achieve, not sit in bitter regret."
>  - Ronan Harris / Mark Jackson
> On Thu, Aug 10, 2017 at 4:39 PM, Frank Geitzler 
> <frank.geitzler at ns.sympatico.ca 
> <mailto:frank.geitzler at ns.sympatico.ca>> wrote:
>     Thanks, for the suggestions, Joel.
>     I opened a terminal on my Lenovo and tried those commands.  I
>     copied the results to a text file named ping_test.txt, and did a
>     screenshot of the network settings window to a file which I named
>     Screenshot....png  as well.  I copied both files to a USB drive,
>     which I moved to my laptop system, on which I am writing this. 
>     Both of those files are attached. Neither ifconfig nor traceroute
>     appear to be on the Lenovo, and the 'Ubuntu Software' application
>     on Ubuntu 17.04, which I installed on it, doesn't appear to have a
>     search function to determine what applications might be available
>     for installation.  I prefer the Synaptic Package Manager, since I
>     am used to it, but it  doesn't appear to be available for
>     installation, and I don't know how I could download it.  I have
>     attached the two files for your information.  How would you
>     interpret the ping test?
>     Frank
>     On 2017-08-09 01:49 PM, Joel Maxuel wrote:
>>     Hi Frank,
>>     I would fire up a shell to see what your network connectivity is
>>     like.  Commands such as:
>>     sudo ifconfig -a
>>     ping
>>     traceroute
>>     The first will tell you the status of your network interfaces. 
>>     If you only have loop setup (no eth0 or eno1, for example), then
>>     although there is hardware link, the network card has not been
>>     initialized (nor did get an IP address).  If an interface is
>>     there but the IP addr starts with 169.254..., you may have some
>>     router config to do.
>>     The other two commands will try to access a sever i always ping
>>     when in trouble, Dept of Education's mail server.
>>     Hope this provides a good start.
>>     --
>>     Cheers,
>>     Joel Maxuel
>>     "One should strive to achieve, not sit in bitter regret."
>>      - Ronan Harris / Mark Jackson
>>     On Wed, Aug 9, 2017 at 1:02 PM, Frank Geitzler
>>     <frank.geitzler at ns.sympatico.ca
>>     <mailto:frank.geitzler at ns.sympatico.ca>> wrote:
>>         I just installed Ubuntu 17.04 on a Lenovo 7360 with a wired
>>         connection to my FibreOp router.  When I open Firefox, it
>>         advises that the server is not found. "Firefox cannot find
>>         the server at ..." even when I type in "www.bellaliant.net
>>         <http://www.bellaliant.net>", although when I enter this
>>         address on my laptop, it is resolved to "aliant.bell.ca
>>         <http://aliant.bell.ca>".
>>         The options provided by Firefox for this problem are:
>>           * Check the address for typing errors such as
>>             ww.example.com <http://ww.example.com> instead of
>>             www.example.com <http://www.example.com>.
>>           * If you are unable to load any pages, check your
>>             computer's network connection.
>>           * If your computer or network is protected by a firewall or
>>             proxy, make sure that Firefox is permitted to access the web.
>>         I compared the network settings in Firefox on the Lenovo to
>>         my existing laptop settings, and they appear identical.
>>         The indication on the screen is that there is a cable
>>         connection to the network (the pair of arrows, one pointing
>>         in each direction, on the top line of the screen).
>>         Do I need to configure anything in the router?  I didn't
>>         think so, but I could be wrong.  How can I check to see if I
>>         am protected by a firewall or proxy?
>>         I could call BellAliant support, but the usual response is
>>         "What is Ubuntu/Linux"?.
>>         I would appreciate any suggestions.
>>         Thanks,
>>         Frank Geitzler
>>         _______________________________________________
>>         nSLUG mailing list
>>         nSLUG at nslug.ns.ca <mailto:nSLUG at nslug.ns.ca>
>>         http://nslug.ns.ca/mailman/listinfo/nslug
>>         <http://nslug.ns.ca/mailman/listinfo/nslug>
>>     _______________________________________________
>>     nSLUG mailing list
>>     nSLUG at nslug.ns.ca <mailto:nSLUG at nslug.ns.ca>
>>     http://nslug.ns.ca/mailman/listinfo/nslug
>>     <http://nslug.ns.ca/mailman/listinfo/nslug>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/pipermail/nslug/attachments/20170811/596abc06/attachment.htm>

More information about the nSLUG mailing list