[nSLUG] grub2 failing on mdadm raid 1, ext4 : error: no such disk

D G Teed donald.teed at gmail.com
Sat May 21 04:15:34 ADT 2011

OK, found my problems.

The boot toogle flag from fdisk had not been set.
I had a feeling there was something overlooked, but
my head was in OS level stuff and all of the newness
I was dabbling in (ext4, metadata level, grub2).

I was't seeing a Grub screen from the intended disk,
as the BIOS was sending me off to the old disk
where I must have done something to affect its grub

I should have tried detaching the original disk way before now.

It was partly compounded by odd behaviours in the Debian
rescue CD for reinstalling the grub.  I was able to launch
the system from SuperGrub 2 and then I found things like
dpkg-reconfigure grub-pc worked fully (not so in rescue
CD chrooted shell to root, even with /var and /usr mounted).

Anyway it's up and running.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/pipermail/nslug/attachments/20110521/c0fec8ad/attachment.htm>

More information about the nSLUG mailing list