[nSLUG] grub2 failing on mdadm raid 1, ext4 : error: no such disk

D G Teed donald.teed at gmail.com
Sat May 21 02:35:34 ADT 2011

On Sat, May 21, 2011 at 12:15 AM, D G Teed <donald.teed at gmail.com> wrote:

> I must be missing a step or have muddled up something I can't spot.
> I know ext4 and grub and mdadm raid 1 work together OK - I've
> seen it on a Redhat 6 install.  On Debian 6 at home I'm
> having the problem while converting to newer disks.
> There are a number of changes from the previous disk setup.
> It is going from ext3 to ext4 on the new disk, and also
> from metadata .90 on mdadm to metadata 1.2 (with name=)
> on the new disk's mdadm.conf lines.
> When setting up the new RAID 1 in mdadm, it did make some
> warning about the metadata 1.2 format, but I didn't write it down.
> Looking at another system I set up for testing this
> stuff, I see mdadm.conf set up with metadata=1.0
> where I've got 1.2.  The working Debian 6 test box has:
> ARRAY /dev/md/0 metadata=1.0 UUID=4a5f0038:e00d175e:6d7faf91:f6648f66
> name=hostname:0
> I wonder if the metadata 1.2 format is an issue?

I've now redone / and /usr partitions with mdadm, using metadata=0.90
to satisfy the grub.cfg references.  In Debian, some of the grub
splash screen or other elements refer to /usr locations, so
two partitions were made compatible in the older metadata format.

In grub rescue I can now at least see the files on the partition,
but still no grub screen on boot up.  I remembered to fix
mdadm.conf and fstab with the new UUIDs from the recreated
and copied (rsync)  / and /usr partitions.

I can run grub-install for /dev/sdb from a chroot shell,
but not by the built-in menu item of Debian's rescue CD.  Odd.

Still no boot, no grub menu.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/pipermail/nslug/attachments/20110521/6243311b/attachment.htm>

More information about the nSLUG mailing list