[nSLUG] HP 8100i CD writer: lost interrupt

Peter Cordes peter at cordes.ca
Thu Aug 26 00:52:53 ADT 2004


On Wed, Aug 25, 2004 at 10:13:18PM -0300, Ashley George wrote:
> Looking on Google for an answer, I found a few pages where some people
> had a similar problem.  They suggested that it was due to ACPI (or
> alternatively, APIC) and variously recommended turning off ACPI and/or
> APIC.  Most of it was voodoo advice. ie, "I tried this and it finally 
> worked, but I don't know why."  So I tried these recommendations, both
> turning off ACPI and APIC via kernel parameters and finally recompiling
> the kernel without ACPI and without APIC.  But there was no change in
> response from the CD writer.

 Have you tried turning off DMA mode (hdparm -d0 /dev/foobar)?  This is more
voodoo advice, but maybe there's something flaky, and slower speeds would
work ok...  Depending on your kernel config, Linux enables dma
automatically.  (There's an option to only enable DMA for hard drives.)

> Does anyone know how I can further diagnose this?  The drive worked
> perfectly with the PCI IDE controller.  I don't yet believe there is 
> anything wrong with the drive itself - I will soon test it in a 
> different computer to be absolutely certain about that.  

 If I think of anything, I'll let you know.  :(


-- 
#define X(x,y) x##y
Peter Cordes ;  e-mail: X(peter at cor , des.ca)

"The gods confound the man who first found out how to distinguish the hours!
 Confound him, too, who in this place set up a sundial, to cut and hack
 my day so wretchedly into small pieces!" -- Plautus, 200 BC

!DSPAM:412d5e9d187379410459259!




More information about the nSLUG mailing list