[nSLUG] tar of fat32 windows xp partition?

Peter Cordes peter at llama.nslug.ns.ca
Tue Jul 29 17:56:33 ADT 2003


On Tue, Jul 29, 2003 at 04:49:43PM -0300, Donald Teed wrote:
> 
> On Tue, 29 Jul 2003, Dop Ganger wrote:
> 
> > The only real gotcha I can think of is it's not an imager; if it's a boot
> > partition you're tarring off, chances are very high you won't be able to
> > boot it if you restore the tar as the boot stuff will be on different
> > sectors. If you're doing this on data partitions it should be fine.
> 
> Yes, that would be a problem in my case.
> 
> If the first 512 bytes of a partition contain the boot information,
> I'd think I could grab that and stuff it into a file that is included
> in the tar.  Then on restore, after it is extracted, dd it
> back to /dev/hda1
> 
> This is probably dependant on the drive geometry being the same
> but in this case I can make that assumption.

 I was just recently trying to copy a FAT32 win2k install to a new hard
drive, and I ran into a couple issues.  Using GNU parted v1.6.5, I copied
/dev/hdc1 to /dev/hda2, and tried to boot, and the NT boot menu came up, but
when I selected win2k, it couldn't find the kernel.  (something like
.../system32/kernelsomething.sys not found).  I rearranged my partitions,
and copied hdc1 to hda1, and windows booted to a graphical screen.  However,
before the desktop came up, it complained about not having enough virtual
memory, and there being no swap file.  (I had 512MB of RAM installed.)  This
error message included instructions for how to change swap settings (using
"my computer"), but the message kept coming up and I never got to a desktop,
so I couldn't set up a swap file.  This happened even in safe mode, but I
didn't try command-line-only safe-mode.  (I don't know how to mess with the
swap file from the win2k command line).

 Maybe partimage would work better, but parted doesn't seem to work very
well for copying a win2k install.  The parted docs describe what to do to
copy a windows install, but maybe that was only tested with win9x?

 For copying my GNU/Linux install, I used cpio -p.  (I was going from ext3
to reiserfs, so I couldn't use anything lower-level).  I went to single-user
mode, and unmounted all directories (including /proc and /dev/pts), and
remounted / read-only before copying, to avoid any weirdness.

-- 
#define X(x,y) x##y
Peter Cordes ;  e-mail: X(peter at cor , des.ca)

"The gods confound the man who first found out how to distinguish the hours!
 Confound him, too, who in this place set up a sundial, to cut and hack
 my day so wretchedly into small pieces!" -- Plautus, 200 BC




More information about the nSLUG mailing list