[nSLUG] upgrading to woody: display problems

bdavidso at supercity.ns.ca bdavidso at supercity.ns.ca
Wed Jun 12 01:48:24 ADT 2002


Hi:

You could manually edit your XF86Config file (usually in /etc/X11) and
make the required changes.

Did you install "woody" on top of an earlier installation?  I ask because
current (4.2) releases of XFree86 don't contain a program called
"XF86Setup" (or is that a Debianism?), and I don't think the S3 server is
called "S3" any more, but "s3virge".  In short, you might be using an
XF86Config from an earlier install or something.  If I were you I would
find and rename your XF86Config file (under /etc or /usr), rename it, and
run "xf86config" to build a new one.

-- 
Bill Davidson
bdavidso at supercity.ns.ca


On Sun, 9 Jun 2002, Joel Maxwell wrote:

> Hello All,
> I finally took the initiative to upgrade my debian homebox to woody
> (I need gimp 1.2 to be able to print with my new epson printer)  and
> I ran into a problem with xfree86.  Whenever i try to run startx now,
> what I get is:
>
> usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/cyrillic,/usr/X11R6/lib/X11/fonts/100dpi,/usr/X11R6/lib/X11/fonts/75dpi"
> PCI: Probing config type using method 1
> PCI: Config type is 1
> PCI: Bus 0x0 Card 0x00 Func 0x0 ID 0x8086,0x7180 Rev 0x03 Class 0x06,0x00
> PCI: Bus 0x0 Card 0x01 Func 0x0 ID 0x8086,0x7181 Rev 0x03 Class 0x06,0x04
> PCI: Bus 0x0 Card 0x07 Func 0x0 ID 0x8086,0x7110 Rev 0x02 Class 0x06,0x01
> PCI: Bus 0x0 Card 0x07 Func 0x1 ID 0x8086,0x7111 Rev 0x01 Class 0x01,0x01
> PCI: Bus 0x0 Card 0x07 Func 0x2 ID 0x8086,0x7112 Rev 0x01 Class 0x0c,0x03
> PCI: Bus 0x0 Card 0x07 Func 0x3 ID 0x8086,0x7113 Rev 0x02 Class 0x06,0x80
> PCI: Bus 0x1 Card 0x00 Func 0x0 ID 0x5333,0x8904 Rev 0x01 Class 0x03,0x00
> (--) S3: PCI: unknown (please report), ID 0x8904 rev 1, Linear FB @ 0xe0000000
> (--) S3: Unknown S3 chipset: chip_id = 0x8904 rev. 1
>
>  *** None of the configured devices were detected.***
>
>
> Fatal server error:
> no screens found
>
> When reporting a problem related to a server crash, please send
> the full server output, not just the last messages
>
> X connection to :0.0 broken (explicit kill or server shutdown).
>
> I have an s3 trio 3d card, and i can't seen to change the driver to plain svga
> (XF86Setup is giving a segmentation fault) so I don't know what else
> to do.  Any suggestions?
>
> --Joel Maxwell
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/cgi-bin/mailman/listinfo/nslug
>




More information about the nSLUG mailing list