[nSLUG] grub-pc unable to install initrd

Jack Warkentin jwark at bellaliant.net
Mon Aug 8 10:54:13 ADT 2016


Hi Donald

I gave up on trying to get the upgrade-to-jessie system working and 
decided to reinstall jessie from scratch. When it came time to do the 
installation of grub, there was a message saying that the installer 
believed my bios to be an efi bios. (I think it was the jessie installer 
rather than the grub installer, but I can't be sure - the logs don't 
show the message).

The message stated that efi bioses tended to be buggy, etc, and did I 
want to continue, which I did. Perhaps it was a buggy bios that caused 
all the problems getting grub to boot my upgrade-to-jessie system. 
Nobody will ever know.

Thanks for your help,

Jack

D G Teed wrote:
>
> On Wed, Aug 3, 2016 at 4:46 PM, jwark at bellaliant.net
> <mailto:jwark at bellaliant.net> <jwark at bellaliant.net
> <mailto:jwark at bellaliant.net>> wrote:
>
>     Hi Everybody
>
>     Until a few weeks ago I was running Debian wheezy on my AMD64/5-year-old
>     ASUS motherboard desktop computer. Before upgrading to jessie, I
>     successfully upgraded grub legacy to grub-pc. The dist-upgrade to jessie
>     worked fine and I was able to boot into the new kernel with no problems.
>
>     A week or so after the dist-upgrade there were a whole bunch of packages
>     that needed to be upgraded, so I did that. Afterwards the system would
>     not boot with grub, although I can boot it with both a systemrescue CD
>     and a Debian jessie installation usb stick, in rescue mode.
>
>     I have checked everything I could think of with no success. I couldn't
>     find any packages in the dpkg logs that would appear to be problematic
>     for booting. All of the grub packages, and the kernel package are dated
>     well before the dist-upgrade, according to the .deb files in
>     /var/cache/apt/archives. I have re-installed those packages and
>     re-installed grub. I have also tried editing the grub boot commands in
>     several ways. Without the initrd the kernel boots but hangs up, as
>     expected, presumably by the lack of the initrd.
>
>     So I am assuming that grub is failing to properly install the initrd.
>
>     Remaking the initrd image hasn't helped. The initramfs-tools package
>     also dates from well before the time of this problem.
>
>     I don't want to do a complete reinstall of jessie if I can possibly
>     avoid it, and I am not even sure that would help. I am using apt pinning
>     to to use systemv init and a complete reinstall would force *all* of
>     systemd on me.
>
>     Does anybody have any suggestions? Would reverting to grub legacy solve
>     the problem? I can install and remove packages using the rescue shell
>     from the debian boot usb stick and do anything else possible with the
>     CLI.
>
>
> Are there any clues here:
>
> http://people.skolelinux.org/pere/blog/How_to_stay_with_sysvinit_in_Debian_Jessie.html
>
> I've experienced running Jessie with systemd and Redhat 7 with systemd.
> Debian has enough
> wrapper stuff you would hardly know the earth shifted out from
> underneath.  There are
> still init scripts, /etc/init.d service commands work just like before.
>   rcconf is still available.
> Conventional logging is still there.  I have not found a reason to avoid
> systemd with
> Debian, but I found Redhat's way has been disruptive to a seasoned
> system administrator.
>
> If you are running grub commands from a rescue boot scenario, always
> mount the system
> on disk and chroot to it so the grub version is the same and the entire
> environment is sane.
> Some rescue modes take care of this already, others do not.  If you need
> to make
> the chroot mount point yourself, don't forget to include /proc /sys and
> /dev under the
> /mnt mount point (e.g. mount -o bind /proc /mnt/proc ) and reverse with
> umount after the chroot is exited.
>
> Most of the notes on how to keep sysvinit are from 2014 so it is
> possible there are
> more difficulties today than there were then.
>
>
>
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/mailman/listinfo/nslug

-- 
Jack Warkentin, phone 902-404-0457, email jwark at bellaliant.net
39 Inverness Avenue, Halifax, Nova Scotia, Canada, B3P 1X6


More information about the nSLUG mailing list