[nSLUG] grub-pc unable to install initrd

Frank Geitzler frank.geitzler at ns.sympatico.ca
Wed Aug 3 23:12:26 ADT 2016


Jack, as you know, I run Ubuntu rather than 'pure' Debian, if I may use
that terminology), but the following file has the list of partitions
used by Ubuntu, and their mount points:
        /etc/fstab
Is the same the case with Debian wheezy, and if so, is it possible that
there is a problem with the referencing of the partitions there?  I
think that file is used by the process that creates the boot loader
Frank Geitzler
 On Wed, 2016-08-03 at 16:46 -0300, jwark at bellaliant.net wrote:

> Hi Everybody
> 
> Until a few weeks ago I was running Debian wheezy on my AMD64/5-year-old
> ASUS motherboard desktop computer. Before upgrading to jessie, I
> successfully upgraded grub legacy to grub-pc. The dist-upgrade to jessie
> worked fine and I was able to boot into the new kernel with no problems.
> 
> A week or so after the dist-upgrade there were a whole bunch of packages
> that needed to be upgraded, so I did that. Afterwards the system would
> not boot with grub, although I can boot it with both a systemrescue CD
> and a Debian jessie installation usb stick, in rescue mode.
> 
> I have checked everything I could think of with no success. I couldn't
> find any packages in the dpkg logs that would appear to be problematic
> for booting. All of the grub packages, and the kernel package are dated
> well before the dist-upgrade, according to the .deb files in
> /var/cache/apt/archives. I have re-installed those packages and
> re-installed grub. I have also tried editing the grub boot commands in
> several ways. Without the initrd the kernel boots but hangs up, as
> expected, presumably by the lack of the initrd.
> 
> So I am assuming that grub is failing to properly install the initrd.
> 
> Remaking the initrd image hasn't helped. The initramfs-tools package
> also dates from well before the time of this problem.
> 
> I don't want to do a complete reinstall of jessie if I can possibly
> avoid it, and I am not even sure that would help. I am using apt pinning
> to to use systemv init and a complete reinstall would force *all* of
> systemd on me.
> 
> Does anybody have any suggestions? Would reverting to grub legacy solve
> the problem? I can install and remove packages using the rescue shell
> from the debian boot usb stick and do anything else possible with the
> CLI.
> 
> Regards
> 
> Jack
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/mailman/listinfo/nslug


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/pipermail/nslug/attachments/20160803/f761d807/attachment.html>


More information about the nSLUG mailing list