[nSLUG] SSD Failed, left with outdated /usr and /opt (before upgrade)

Joel Maxuel j.maxuel at gmail.com
Thu Oct 30 17:43:43 ADT 2014


Turned out to be a false alarm.  Was getting the SSD out to start an RMA,
and upon opening the case, I see a loose lead in a Molex connector.  I push
it back in, turn the PC back on, and it starts faster.  I uncomment the
lines for sdb, move the /usr and /opt folders around again, and reboot, and
everything is back to normal!

So it looks like all I need to do (eventually - right now the loose wire is
taped in place with the help of other wires) is buy a new $3 Molex adapter.


--
Cheers,
Joel Maxuel

"One should strive to achieve, not sit in bitter regret."
 - Ronan Harris / Mark Jackson

On Thu, Oct 30, 2014 at 5:26 PM, Joel Maxuel <j.maxuel at gmail.com> wrote:

> So I am in a bit of a pickle.  I know the easy way out, but I don't want
> to take it (at least not yet).
>
> I came home to find my secondary hard drive, an SSD, has failed.  As the
> computer was slowly crashing, my console was spitting up errors like:
>
> [346603.687525] end_request: I/O error, dev sdb, sector 19128568
>
> In the off chance that a reboot fixed it, I did that (albeit not with the
> "reboot" command as that is a /usr app)
>
> POST was slow, and did not pick up the drive.  INIT tried to, but failed
> twice with:
>
> ata4: SRST failed (errno=-16)
>
> I managed init 1 as fsck failed as well, and was able to log in.  I edited
> my fstasb to not include the mount points for /usr and /opt effectively
> saying "don't even try".  I then renamed my old /usr and /opt, from
> /usr-old and /opt-old, respectively.  I then rebooted again.
>
> If only that was enough.  See, I didn't keep my old folders up to date, in
> fact they were abandoned directories when I got my SSD a year and a half
> ago.  I upgraded to Wheezy in that time most notably.  So my reboot didn't
> really accomplish much.  Still stuck in console.
>
> I tried and aptitude upgrade, and even dist-upgrade.  That created a tonne
> of unmet dependencies, 50-some packages to remove, some I want, like Wine.
> Is there a quick and dirty apt-get command that reinstalls all packages, at
> their version, and ignores dependencies?
>
> The alternative is that I reinstall, but I don't have an amd64 CD right
> now, nor my backup drive, so I am hesitant on blasting everything away.
>
> Any other routes I should pursue?
>
> --
> Cheers,
> Joel Maxuel
>
> "One should strive to achieve, not sit in bitter regret."
>  - Ronan Harris / Mark Jackson
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/pipermail/nslug/attachments/20141030/f25fa7c4/attachment.html>


More information about the nSLUG mailing list