[nSLUG] Audio Issues (ALSA + Webcam + Adobe Connect, others)

Joel Maxuel j.maxuel at gmail.com
Sat Mar 29 17:27:13 ADT 2014


Good day all,

I brought up my journey (sorry for the long post) for the perfect sound
configuration at the last NSLUG meeting, and I made a little progress.
Essentially at the time I had a headset mic that I was unable to record
from, which would be useful for Skype and video conferencing apps like
Adobe Connect.  In the progress of this, I removed PulseAudio (forgetting
what all I needed it for), leaving ALSA as my go-to sound server.

I haven't had any issues with the removal, I could select the appropriate
mic in GNOME's sound recorder (although for the record my DM is XFCE, on a
Debian Wheezy box), but I was still unable to record anything (silent).  I
then tried the headset on a different (Windows) computer.  Still nothing,
so I determined that the mic has passed it's time.

My webcam was getting old was well (the headset came with the device in
lieu of a built in microphone) as it wasn't being recognized by Adobe
Connect (or any flash-based software, like testmycam.com).  So I went out
and purchased a Logitech C170.  The camera picked up immediately (once I
switched from Camorama - which was locking up - to Kamerka), and with a
little bit of code in my .asoundrc...

# Thanks to http://forums.debian.net/viewtopic.php?f=7&t=81039
pcm.!default {
type asym
playback.pcm {
type plug
slave.pcm "hw:0,0"
}
capture.pcm {
type plug
slave.pcm "hw:1,0"
}
}

...I can record sound, and use Skype (and without having to select the
input source).

Then last night happened.  I opened MeTV while Exaile was paused and
complained that sound was not available.  Same with Kaffiene.  Had I
stopped the music in Exaile the problem would have gone away.  I think at
the time that Iceweasel was still able to process sound as my Facebook
would have been making notification sounds.  I realized that the reason I
had PulseAudio was to keep KDE/Qt apps happy (since it seems KDE wants
pulse to process audio).

I put PulseAudio back on, and this was when my webcam mic failed to work.
Sound recorder could only select "Master" for input source, and I was
unable to define what Master was in the XFCE mixer.  So in a flurry, I
ditched pulse (again).  Rebooted, and this time, only one application, no
matter the colour (GTK, Qt) could play sound at a time.  I found another
asound.conf example fixing this (
http://www.filewatcher.com/p/alsa-lib_1.0.23-2.1.debian.tar.bz2.424533/debian/examples/asound.conf_dmix.html),
and included it into my .asoundrc (so now I have)...

pcm.!default {
        type plug
        slave.pcm "dmix"
}
playback.pcm {
        type plug
        slave.pcm "hw:0,0"
}
capture.pcm {
        type plug
        slave.pcm "hw:1,0"
}

# Make OSS apps default to using dmix plugin too
pcm.dsp0 {
        type plug
        slave.pcm "dmix"
}

ctl.mixer0 {
        type hw
        card 0
}

This allowed Exaile play nicely with Iceweasel (and any GTK app I could
find), but still not with Qt.  That's fine.  The automatic selection of the
webcam mic that I enjoyed before, well, I have to manually select in
settings (which is easy in Skype, but I had to switch sound recorders to
Audacity), which is okay as well.

I could live with this.  But then came the final test.  Adobe Connect.  I
use video conferencing software with a group I'm in, and although we are
still figuring out which software to use (have tried Fuze as well), Adobe
Connect has been the preference.  With Adobe Connect, I can hear the test
sound, but I am unable to record, and the sound does not work at all while
connected.  I'm thinking this one is requiring PulseAudio after all (due to
no sound at all for the test sound when I had music paused).

This is all to say I think I need PulseAudio back onto my system, but I am
at a loss on how to configure it to my needs (to auto select the webcam mic
- I don't think I'd ever use another input source).  I assume this is
controlled by asound.conf, so does anyone (likely with a similar setup)
have a conf file I could borrow?

Secondary question... I see that part/all of the Adobe audio issue can be
fixed with this:
http://helpx.adobe.com/adobe-connect/kb/no-audio-playback-ubuntu-add.html
If the above to solutions take me nowhere, is there a video conferencing
program you would recommend?  The requirement is that it is free (as in
beer - although I don't think what I'm currently using is free, it's free
to use thanks to another organization) and multi-platform (there will be
Windows and Mac users using it as well).  We use desktop sharing as part of
the function, if that makes a difference.  We tried Fuze, and it held
promise, but it keeps crashing on my PC now (the Linux client was designed
for Ubuntu - the oldest version would fail to load, without showing any
error in GUI or terminal - the newer versions would just lock up after
logging in).

Thanks for lending an ear while I babble on forever.

--
Cheers,
Joel Maxuel

"One should strive to achieve, not sit in bitter regret."
 - Ronan Harris / Mark Jackson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/pipermail/nslug/attachments/20140329/24c9d4c9/attachment.html>


More information about the nSLUG mailing list