[nSLUG] Installation problems, Fedora 18

George N. White III gnwiii at gmail.com
Wed Jul 3 15:27:42 ADT 2013


Online PC specs are often wrong -- even for the same model the precise
components can vary between machines ordered at the same time and shipped
together.   This is less of a problem with enterprise class (Dell Optiplex)
as opposed to consumer (e.g., Costco, Best Buy, ...) boxes.


On Wed, Jul 3, 2013 at 1:43 PM, Cliff Cameron <treephrog at gmail.com> wrote:

>
> Probably all after the fact, but here's where I ended up.
>
> Google search for "h8-1513cb hp pavilion" returns nothing terribly
> interesting, notably there's no hp.com results until the bottom the page.
> Further, there's a link to the CostCo page for the system, but it's no
> longer available.
>
> Going to HP's site and doing the same search reveals a 1520t as the
> closest result; not an exact match. More than likely, the 1513cb is a model
> made specifically for CostCo, so we may have to reverse-engineers some
> specs to see if we can figure out some hardware details.
>
> Since this is the next model up in the chain, we can assume that the specs
> will be similar, albeit probably slightly lower:
>
> http://www.shopping.hp.com/en_US/home-office/-/products/Desktops/HP-ENVY/C9D47AV?HP-ENVY-h8-1520t-Desktop-PC
>
> The "Specs" tab tells us that this model ships with an AMD Radeon HD 7670
> video card, so it's probably safe to assume that Vlado's machine has a
> similar, but probably slightly lower performance, video card. Last mention
> of the video card in the email thread states that the video seems to be
> working okay, so this isn't terribly helpful, other than perhaps updating
> to restricted drivers for (possibly) increased performance.
>
> The network card is more sticky.
>
> Searching for "h8-1513cb hp pavilion ethernet chipset" doesn't yield much,
> either, although the second search result is interesting, even though the
> actual page wouldn't load properly a few times:
>
>
> http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c03517389&prodSeriesId=5295996
>
> HP ENVY h8-1414 Desktop PC Product Specifications. Product *...* Chipset:
> AMD 970. Memory *...* Technology: RTL8171EH-CG Gigabit Ethernet Controller
> .
>
> So this model is a few below Vlado's machine. Might be a good starting
> point to do trial-and-error with drivers, providing the Realtek RTL8171EH-CG
> chipset is supported.
>
> Using the search on that specs page to search
> for h8-1515, h8-1510, h8-1520 got no results.
>
> If I had to guess, I'd bank on the system using a Realtek chipset for the
> ethernet, and I wouldn't be surprised if it was the RTL8171EH-CG, or one
> very close to it.
>
> Hope this helps in some way.
>
> Cliff
>
>
>
>
> On Wed, Jul 3, 2013 at 8:56 AM, George N. White III <gnwiii at gmail.com>wrote:
>
>> Just trying different distros may not be very useful, it is much better
>> to find out what ethernet hardware is in your machine and investigate the
>> linux support for your device.  Often it is just a question of tweaking the
>> configuration.  The kernel may be loading the wrong module or loading the
>> right module with the wrong options.  Newer distros tend to use a dynamic
>> network configuration more suited to laptops where you may be plugging and
>> unplugging ethernet cables and moving between wireless AP's.  For always on
>> servers it is better to use a static network configuration, but if you use
>> sleep or hibernation with your desktop a dynamic configuration may be
>> better but at a cost of more opportunities for configuration glitches.
>>
>> Normally, lspci will tell you what device you have, and google or the
>> vendor's website will tell you the status of linux support.  I'm sure if
>> you post the lspci entry someone will help track down the linux status info.
>>
>>
>>
>> On Tue, Jul 2, 2013 at 10:52 PM, Vlado Keselj <vlado at cs.dal.ca> wrote:
>>
>>>
>>> I was thinking about using one of the older network cards, but using
>>> a USB Ethernet adapter seemed like a similar but easier solution (rather
>>> than opening a new computer etc.)
>>>
>>> When I have a chance, I will run with some other Live distributions to
>>> see
>>> if the built-in Ethernet is recognized.
>>>
>>>
>>>
>>> On Tue, 2 Jul 2013, George N. White III wrote:
>>>
>>> > It isn't unusual to run into problems with linux on new hardware.  The
>>> first thing to investigate is whether the devices causing problems
>>> > work with linux -- some vendors actively support linux while others
>>> make it difficult for developers to get access to the technical
>>> > details.   It is silly to just randomly try different distributions
>>> without knowing what drivers your hardware needs since google should
>>> > find the appropriate drivers given the hardware details.  With
>>> consumer gear the only reliable way to know what is in your box is to run
>>> > lspci and check dmesg and Xorg.0.log.  If you can't get the video to
>>> work many distros have text mode installs or rescue boot options that
>>> > give a text console.  Consumer distros often fix hardware issues in
>>> upgrades, so don't assume Fedora 18 won't work based on the DVD.
>>> >
>>> > In my experience, sound is the one device category that distros handle
>>> differently so if you need sound and have problems with Fedora 18 (I
>>> > have not got sound to work in a Fedora 18 OpenBox VM, but Ubuntu
>>> worked without
>>> > any fuss) then it might be worth trying some other live DVD's.
>>> >
>>> > It sounds like you have video and onboard network problems.  For video
>>> the vendor may have non-free drivers that work while the bugs are
>>> > still being worked out of the free drivers.  If the onboard ethernet
>>> isn't supported you can install a card that does have good support.  A
>>> > few years ago I was seeing problems with low-end ethernet chips
>>> intended for Windows web browser level applications that just did not work
>>> > properly with linux and had to be disabled and a server-class card
>>> added.  Watch out for used ethernet cards -- I've seen lots of cards
>>> > that pass the vendor's diagnostics but were useless for moving data --
>>> some even managed to pass the diagnostics with several components
>>> > that had been incinerated -- I suspect users tried to plug a phone
>>> wire into the ethernet jack instead of the modem jack.
>>> >
>>> >
>>> >
>>> > On Tue, Jul 2, 2013 at 8:02 AM, Vlado Keselj <vlado at cs.dal.ca> wrote:
>>> >       Hi,
>>> >
>>> >       I am trying to install Fedora 18 on a new desktop (h8-1513cb HP
>>> Pavilion,
>>> >       from Costco).  After solving Windows 8 "Secure boot" problem, it
>>> seems
>>> >       that built-in Ethernet is not recognized and the display is
>>> shifted (a
>>> >       right part appears on the left side).
>>> >
>>> >       Has anyone had similar problems?  Do you have any
>>> recommendations about a
>>> >       good Linux distribution for new hardware?
>>> >
>>> >       Thanks,
>>> >       Vlado
>>> >       _______________________________________________
>>> >       nSLUG mailing list
>>> >       nSLUG at nslug.ns.ca
>>> >       http://nslug.ns.ca/mailman/listinfo/nslug
>>> >
>>> >
>>> >
>>> >
>>> > --
>>> > George N. White III <aa056 at chebucto.ns.ca>
>>> > Head of St. Margarets Bay, Nova Scotia
>>> >
>>> >
>>>
>>> _______________________________________________
>>> nSLUG mailing list
>>> nSLUG at nslug.ns.ca
>>> http://nslug.ns.ca/mailman/listinfo/nslug
>>>
>>>
>>
>>
>> --
>> George N. White III <aa056 at chebucto.ns.ca>
>> Head of St. Margarets Bay, Nova Scotia
>>
>> _______________________________________________
>> nSLUG mailing list
>> nSLUG at nslug.ns.ca
>> http://nslug.ns.ca/mailman/listinfo/nslug
>>
>>
>
>
> --
> "Stat rosa pristina nomine, nomina nuda tenemus."
> +++
> "Carpe Noctem."
>
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/mailman/listinfo/nslug
>
>


-- 
George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/mailman/private/nslug/attachments/20130703/9f7c5ab4/attachment-0001.html>


More information about the nSLUG mailing list