[nSLUG] Upcoming meeting + a juicy question

robbie macg robbie.macg at gmail.com
Sun Aug 4 19:37:05 ADT 2013


Hi,
I appear to have sorted out my own solution to the previously shared issue.
I'm not sure how elegant a solution I deployed, but I can now
mount/back up via CLI. I've now automated things so that twice a day
my production desktop will send files to a remote location available
to other, non-technical members of my team. They can
search/view/download relevant files via ownColoud's friendly web UI, I
can go on about my business.

In order to implement my solution I had to do two things:
Install/implement 'davfs2' (so I could properly mount the dav via CLI
and set a sensible path), sort through a batch of error messages till
I figured out what groups of files to exclude from my 'rdiff-backup'
call. (Hint, I back up/share files between my production machines
[laptop/desktop] using 'git' and 'sparkleshare', and some of the '.'
entries related to those backups were messing everything up.)

Thanks for listening and thanks for your patience.

Robbie

On 4 August 2013 16:58, robbie macg <robbie.macg at gmail.com> wrote:
> Hey gang,
> 1- I'm starting to get really psyched for this month's meet up! I've
> just changed jobs, no longer have to work Monday nights, will be able
> to attend NSLUG events on the regular!
> I wasn't able to get my act in gear this time around, but I might
> pitch a brief talk about the use of fail2ban to thwart botnets for
> next month. Anybody else have to do anything fun/interesting during
> that big WordPress attack this summer?
>
> 2- I'm wondering if anybody with a better grasp of networking stuff
> wants to help me figure out where I'm dropping the ball with a little
> project I’m working on.
> I'm trying to  back up some files to a shared work server via 'rdiff-backup'.
> I have the relevant directory mounted locally, can see/copy file to a
> dav directory via Nautilus no problem. When I try to 'cp' material or
> use 'rdiff-backup' I get a whole whack of errors.
> I've tried calling the destination variously:
> '/run/user/robbiemacg/gvfs/dav:host=192.168.1.101,ssl=false,prefix=%2Fowncloud%2Fremote.php%2Fwebdav/PUBLISHING'
> 'dav://192.168.1.101/owncloud/remote.php/webdav/PUBLISHING'
> '/run/user/robbiemacg/gvfs/dav://192.168.1.101/owncloud/webdav/PUBLISHING'
> I've tried various levels of privileges, etc.
> Any thoughts on why I can move material around via GUI and not using
> command line tools? Am I referring to the dav incorrectly (bad path)?
> I don't think that's likely the case as my first 'rdiff*' action
> created a directory on the dav (but failed to copy files).
> *Note that this is an ownCloud directory, so I want to avoid
> workarounds that involve me copying directly to the data directory and
> breaking the database in the process.
>
> Thanks and talk to you soon,
> Robbie
>
> p.s. Let me know if you want to see a paste of my error msgs.


More information about the nSLUG mailing list