[nSLUG] Reply Re: MPlayer subtitle problem

Frank Geitzler frank.geitzler at ns.sympatico.ca
Tue Apr 23 10:15:30 ADT 2013


Mike, I have no magic incantation, but if I recall ancient history
correctly, the sequence '0D0A' translated as 'Carriage Return (0D)
LineFeed (0A).  You might try replacing the linebreak with just '0D',
rather than '0A', if you haven't tried that already.
Good Luck!
Frank Geitzler

On Tue, 2013-04-23 at 03:51 -0300, Mike Spencer wrote:
> Picked up a DVD of Henry V (MGM, 1989), no English subtitles on disk
> but I downloaded a .srt subtitle file to use with it. [1] It's the
> simple format with entries like:
> 
>     733
>     00:57:52,596 --> 00:57:55,963
>     and quickly bring us word
>     of England's fall.
> 
>     734
>     00:59:18,890 --> 00:59:20,482
>     Come. Come in.
> 
> 
> The subtitles work with MPlayer, are synched correctly with the sound
> track.  But they just stop between the two records in the above
> example.  After a minute or so, they start again but they go back to
> record #1 from the beginning of the prologue.
> 
> Google has turned up a very little about a somewhat similar problem
> from 2008 but I've downloaded and compiled the most recent version
> of MPlayer (1.1).
> 
> The subtitle file contains no non-ASCII characters.  I tried replacing
> the 0D0A linebreaks with just 0A, still fails at the same point. I
> can't spot any typos or logical errors near the point of failure such
> as "stop before start" or leaps ahead in time.
> 
> Before I go off to to dabble in the MPlayer mailing list (where I was
> treated rudely the last time I asked a question), does anyone have a
> clue, pointer, hack or magic incantation to help me here?
> 
> Tnx,
> - Mike
> 
> 
> [1] Hard of hearing, y'know?  Speech discrimination loss. DVDs are a
>     big win for me becuase I can always have English subtitles.  Well,
>     *almost* always.
> 




More information about the nSLUG mailing list