[nSLUG] Problem with efax & USR Faxmodem

Dop Ganger nslug at fop.ns.ca
Tue Nov 20 16:09:40 AST 2012


On Tue, 20 Nov 2012, Mike Spencer wrote:

> I've never done fax with a computer before but a need arose.  So I
> fetched efax 0.9, compiled, suitably edited the script that's the
> usual interface to the ELF executable.
>
> Tested by sending a fax to a friend.  Worked great.

So the fax infrastructure per se tested functional at least once. Were you 
faxing to another fax/modem, or to an actual fax machine?

> When I tried to send a fax to the important destination, though, I
> saw:
>
>    + Dials audibly
>
>    + Begins generating the fax handshake tone/beeps.
>
>    + Remote line rings three times
>
>    + Click. No tones, no voice mssg, no BUSY signal. Just "click".

You have probably got the modem set to go silent as soon as it hears 
carrier; I know with data connections you get to hear the full negotiation 
but fax I think cuts out as soon as V.8 comes in. Try setting M2 in your 
init and/or dial string to force speaker on all the time.

>    + efax times out, reports "no answer"

The faxing side always sucked for diagnostic information. ATI6 or ATI11 
*might* give you a hint if you can get in there without resetting 
anything, but it sounds like failure to negotiate.

> Anyone have experience with faxing with this hardware or with the
> hardware/software combination and know what's going wrong?  Hints?
> Pointers?  WAGs?

I've never used efax but I have plenty of experience with the faxing side 
as I wrote the localisation code for USR modems in the UK, albeit a very, 
very long time ago. My first guess would be to try using class 2.0 if 
you're using class 1 faxing, or if you are using class 2.0 use class 1.

Also make sure the bit rate on the serial port is set high enough that it 
won't choke sending data through; 38400 or 57600 should do the trick, or 
115200 if your hardware can take it (ie, 16550 UARTs).

Cheers... Dop.


More information about the nSLUG mailing list