[nSLUG] New Firewire Stack / ffado problems

Herb htheriault at gmail.com
Fri Nov 11 16:34:43 AST 2011


Is anyone using the new firewire stack for audio / video? I'm trying
to run jack with an external fw device and it looks like a permissions
problem, but I'm not sure that it is:

Run as root or normal user I get the same result:

=============
[root at caladan ~]# jackd -P70 -dfirewire  -p128 -n2
jackd 0.121.3
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben
Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

could not open driver .so '/usr/lib/jack/jack_net.so': libcelt0.so.2:
cannot open shared object file: No such file or directory

JACK compiled with System V SHM support.
loading driver ..
01950470462:  (ffado.cpp)[  92] ffado_streaming_init: libffado
2.999.0-2002M built Nov 11 2011 15:55:34
firewire ERR: Error creating FFADO streaming device
cannot load driver module firewire
no message buffer overruns
=============

modules are loaded:
[root at caladan ~]# lsmod | grep fire
firewire_ohci          29650  0
firewire_core          50872  1 firewire_ohci
crc_itu_t               1363  1 firewire_core

and changing device permissions does not help.

I'm running 64bit Arch, and went as far as compiling latest libffado
svn, with the same result.

Any ideas?

Thanks,

Herb



More information about the nSLUG mailing list