[nSLUG] Help: CPAN session "killed", "0-order allocation failed"

Mike Spencer mspencer at tallships.ca
Thu May 14 04:07:34 ADT 2009


What do you know?  I've been using this machine for a couple of years
and swap apparently has never been enabled.  I recall seeing zeros
after the "Swap:" line in /usr/bin/top but thought it just meant that
none was being used.  Nothing I ran ever failed for lack of memory.

So:

    +  Entered a suitable line in /etc/fstab, ran swapon,

    +  After further frustration, corrected a typo in that line, ran
       swapon again.

Now swap is working and so reported by top, free and "cat /proc/swaps".
Haven't tried a cpan connection to a server but ran it locally and it
appeared (from /usr/bin/top) to max out both 256M RAM and 500M swap
during some kind of module-testing phase.  And I still get that system
error message in dmesg, despite apparent graceful and successful exit
of cpan.

But it's progress.

Now I have to see if I can figure out how to actually *install* new
perl modules.  I think I may go for manual fumbling around.  There are
too few lucif documentation writers.  Grumble...


Thanks for the pointers,
- Mike

-- 
Michael Spencer                  Nova Scotia, Canada       .~. 
                                                           /V\ 
mspencer at tallships.ca                                     /( )\
http://home.tallships.ca/mspencer/                        ^^-^^



More information about the nSLUG mailing list