[nSLUG] Help: CPAN session "killed", "0-order allocation failed"

Hatem Nassrat hnassrat at gmail.com
Wed May 13 23:48:55 ADT 2009


On Wed, May 13, 2009 at 8:34 PM, D G Teed <donald.teed at gmail.com> wrote:
>
>
> On Wed, May 13, 2009 at 5:13 PM, Mike Spencer <mspencer at tallships.ca> wrote:
>> So I added a line to /etc/fstab referencing /dev/hda1 as swap, ran
>> swapon -a as root.  Then I tried the cpan command again.  This time,

I tried following this, not sure if this was mentioned before. This
/dev/hda1 was formatted as swap space originally, correct? It doesn't
happen to be the same disk as your root partition (i think that would
be impossible to do anyway).

>> not only did cpan die, the shell, the instance of emacs in which the
>> shell was running and X all died, leaving me at the command prompt in
>> the console from which X had been started.  And dmesg reported:
>>
>>    __alloc_pages: 0-order allocation failed (gfp=0x1d2/0)
>>    VM: killing process xterm
[...]


> Random failures always makes me suspect hardware.
> It was the main thing I learned via Gentoo back in 2003.
> If compiling the same code fails at different points you
> could have bad RAM.

Its either that or your C libraries are royally screwed. Is it just
this that fails, I am inclined to think that your machine shouldn't be
working at all. Were you by any chance upgrading your system and your
kernel or experimenting with your kernel.

Other possibilities are you recently or have always had incompatible
ram. I find that you should try to have the same brand of ram chips.
Mixing ram chips of different types, even from the same vendor may
cause issues. Well its mainly all these different timings on the rams
that cause conflicts. If you want to confirm it has nothing to do with
your ram, either install memtest on your system, and boot to it:

   http://forums.theplanet.com/index.php?showtopic=40256

or use a live cd, any sane distro should have memtest86 as one of the
boot options on the livecd. Test out your ram, and see if it is
functioning. Go through atleast one full pass before killing it, and
dmake sure you get 0 errors.

-- 
Hatem Nassrat



More information about the nSLUG mailing list