[nSLUG] Data Recovery... ;-)

David Potter dlpotter at eastlink.ca
Wed Feb 4 11:50:29 AST 2009


It appears as if the problem was a corrupted superblock on the root file 
partition.

In some respects this seems odd because the first indication of problems 
was corrupted directory rendering on two data partitions which were 
located on a separate physical drive.

As I noted in a previous post, syslog suggested the problem was 
escalating so I took the system down to think about things.

I reviewed the documentation and discussions relating to various 
utilities, dd, dd_recover, ddrecover, TestDisk, and GNU ddrescue. To be 
honest, I never found enough information on dd_recover/ddrecover to make 
an informed decision on those (if they actually exist as more than a 
typo... they could use a wiki page.;-).

In the end I purchased a similar sized disk, formated it with 
similar/identical partitions for the data 'recovery' and  decided to try 
GNU ddrescue. (The 'info' file for ddrescue offers good examples and 
strategies.)

---

ddrescue can be run to retrieve the easily accessible data and then 
rerun to try harder to retrieve blocks and infill the data missed during 
earlier passes - it also can be run against separate copies of a 
file-system (dvds for instance) and improve the data recovery expectation.

Given how much information was on the drive I launched ddrescue with 
some trepidation...  expecting the program to report errors 
immediately....  it didn't!  (report any errors...!!!!)

I ran ddrescue on the second partition with equally benign results!

On s-ata partitions (and with no errors) ddrescue reported processing 
163GB with an average transfer rate of 64,557 kB/s and a second 
partition of 250GB with an average transfer rate of 61,195 kB/s.

After I recovered from the shock over the lack of errors I ran fsck on 
the data partitions with no errors except unclean unmount.

fsck on the root partition offered lots of minor complaints but on 
completion, the system booted fine and mounted the data partitions with 
no problems.

I suspect that the original problem was caused by my resetting the 
system while a boot was in progress... see next post for that tale of 
horror, danger and suspense (hardware...)

david






More information about the nSLUG mailing list