[nSLUG] Apache

D G Teed donald.teed at gmail.com
Thu Aug 6 22:04:05 ADT 2009


On Thu, Aug 6, 2009 at 9:24 PM, <shtower at eastlink.ca> wrote:

> I've been trying to set up a web server under Fedora Core 11 using my old
> Acer Aspire 3860 laptop. I installed the Apache server software and enabled
> and started the httpd service. When I open my web browser, and type "
> http://localhost", I'm presented with the index.html test page that I put
> into the directory "/var/www/html." I have no trouble accessing my test page
> from the computer running Apache, but I can't access the page from any other
> computer. I tried typing "http://[my ip address]", and "http://[my ip
> adress]:80" with no luck. I did open up port 80 on my router, and I tried
> changing the port from port 80 to port 8008 by editing the "Listen" line in
> the httpd.conf file, but I still got the same results. Can anyone tell me
> how to access the website on my server from another computer, or know of a
> fairly "user friendly" Apache tutorial? Also, I read somewhere that some
> ISPs prevent people from using port 80 to run a web server. Does anyone know
> if Eastlink does this?
>
>
It isn't clear whether this is something like an iptables problem or the
router
setup isn't doing the port forwarding you need.

Can you test from another computer on your home network? That will tell
which
of the two is the issue.

A line like this in /etc/sysconfig/iptables will help:

-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j
ACCEPT

Change the chain name to whatever Fedora uses.  Make sure it is above the
last line containing the REJECT rule.  Then do " /etc/init.d/iptables
restart "

If access works from the home network but not from the outside internet,
then you have a router problem which can likely be set up with
a proper port forwarding rule.

Another test is to check what interface the service is listening on.
Depending on the hosts file set up and apache defaults, this
can get messed up.  I usually use something like:

# lsof -Pni | grep ":80"

If you see it is listening only on 127.0.0.1:80, then this is the problem.
Typically people see an entry "TCP *:80 (LISTEN)" and this indicates
it will listen on all available interfaces.

--Donald
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/mailman/private/nslug/attachments/20090806/8534906c/attachment.html>


More information about the nSLUG mailing list