[nSLUG] ethernet and the modern linux

D G Teed donald.teed at gmail.com
Mon Sep 29 00:15:33 ADT 2008


On Sun, Sep 28, 2008 at 2:06 PM, George N. White III <gnwiii at gmail.com> wrote:
> I'm not sure what my debian (unstable) system, a Dell Optiplex GX1 PIII with
> 3com is doing.   I tried adding a file in modprobe.d to force full-100 on the
> 3c59x module.    It seems to be working if I manually remove the module and
> then load it, but on boot dmesg has something to the effect that
> "autoneg failed,
> using half-duplex".  Eventually the system connected with full-100
> (probably when
> /etc/init.d/networking was run -- ntpd was able to connect to a
> server).  It hasn't
> been long enough to see if that system still does "autoneg failed,
> using half-duplex".

Ugh.  I retired all of my Etherlink III gen NICs a few years ago.
Check the docs under:

/usr/src/linux-source-2.6.18/Documentation/networking/vortex.txt

for some tips on forcing full duplex.  You have probably tried them.

In my experience, a $10 NC100 I picked up in
Greenwood mall is more reliable than the 10 year old
3COM cards.  I'd do that rather than spend
time fighting it with kernel options.  Back when NICs were
over a hundred bucks, it might have been worth sweating it.

--Donald



More information about the nSLUG mailing list