[nSLUG] Virtualbox problem (was Re: Debian vserver kernel)

Daniel Morrison draker at gmail.com
Fri Nov 7 17:04:52 AST 2008


2008/11/7 Eugene Cormier <eugene.cormier at gmail.com>:
> and that just worked for me......but I assume (maybe incorrectly) any
> mount/umount command must be run as root for any filesystem under
> debian/ubuntu right?!? .....unless of course you change permissions on
> mount/umount....

Can't say about Debian in particular, but  no.  'mount' is setuid root
precisely so that ordinary users can mount 'user(s)' or 'owner'
filesystems.  See the mount(8) man page:

       (iii) Normally, only the superuser can mount file  systems.   However,
       when  fstab contains the user option on a line, then anybody can mount
       the corresponding system.
...
       For more details, see fstab(5).  Only the user that mounted a filesys-
       tem can unmount it again.  If any user should be able to unmount, then
       use users instead of user in the fstab line.  The owner option is sim-
       ilar to the user option, with the restriction that the  user  must  be
       the  owner of the special file. This may be useful e.g. for /dev/fd if
       a login script makes the console user owner of this device.

I have never tried a Linux install inside VirtualBox (never had a need
for that) but I tried many times to share a folder from my host OS
(CentOS 4) to the guest OS (WinXP) in VirtualBox 1.6.4, following
Sun's instructions.  No matter which way I tried it, it never worked.
I eventually gave up, and hope that an upgrade to VirtualBox (it's at
version 2.0.4 now) would fix it, but I haven't tried yet.

Just a note -- for Linux virtual hosts, I'm using an OpenVZ setup in
CentOS 5 that was setup for me, and have no cause to complain, it
works very, very well.

-D.



More information about the nSLUG mailing list