[nSLUG] USB storage hot-swap question

Rich budman85 at eastlink.ca
Sun May 18 01:27:46 ADT 2008



Mike Spencer wrote:
> Rich> I've tried stick reader and hub reader - I get some issues with
> Rich> kernel freezing, but I think its a bug in the udev rules. (need
> Rich> some time to troubleshoot).
> Rich> [....]
> Rich> I find udev/hal works much better than hotplug ever did.  :)
>
> Part of the reason I haven't upgraded to 2.6 kernel: I've read (but
> haven't understood) mention of bugs in the wonderful new udev.  I'm
> not really intimidated by recompiling a kernel -- did it once to get
> $I_FORGET_WHAT to work -- but I'm not keen on spending a lot of time
> hacking the kernel, even at the Mickey Mouse level.
>
>   

The version in 12.1 uses the latest releases.  I know there were some 
issues last year,
but that was then.   They seem to have settled on some standards and it 
seems to be
paying off.

It seems all the distros are agreeing with the recent rules.d files to
use levels instead of just files.  This seems to have solved a lot of the
problems.

> Rich> BTW, Slackware 12.1 is out.  I've been using the beta for a
> Rich> while, its worth the update, lots of fixes and cleanup.
>
> I've made myself a bit of a problem by not ugrading from Slack 10.1 to
> 11.x.  I gather from browsing the relevant upgrade READMEs that a jump
> from 10.1 to 12.1 just isn't supported by the upgrade scripts.  So my
> plan is to get 12.1 up on my (new, old) Dell P4, then simply take the
> windoes route on the other computers:  wipe the / partition and
> install Slack 12.1 from scratch. Tedious, given all the indiosycratic
> fiddles that have to be redone, but less error prone than trying to do
> an "upgrade" that isn't supported.
>
>   
Yes - do a clean install.  Too many differences to do a straight upgrade.
I found lots of older config file changed names and locations.
It can lead to troubleshooting P.I.T.A. and you end up smacking your head,
because you find you were the cause of the problem. :)


> George> The trick for older hardware is to stiick with a lightweight window
> George> manager. 
>
> I use twm and no "desktop environment".  Anything above 486 seems to
> handle that okay. My current IBM P3 is "*old* hardware"?   Awwwww... :-)
>
>   
twm is still there, so is blackbox and XFCE, which worked nice on a 
K6-III 450.
The only thing I wish they'd fix is the filemgr - I find it sluggish if 
you enter a dir
that a lot of files... like /usr/bin.   It takes a few seconds to 
refresh.  Other than
that, the system works great.  Very stable.

You can always use icewm too if you want lightweight desktops.

If anything - I want to go back to Firefox 2.0.0.11 - whatever they did 
in 12 and upward
really messed with the browser.   I think there may be a bug in the CSS 
module,
because certain seem to stop responding and refreshing after the browser 
is open for
more than 90 hours.   I think it might be some garbage on the stack or 
something.
Its only certain pages too.  Others are having the issue, so I added my 
experiences
to the bug list.

> George> Look in the manuals -- does it say "only for keyboard and
> George> mouse".  Again, I'd avoid USB 1 and get a USB 2 card.
>
> Manuals? All my computers are 2nd hand from (what any self-respecting
> marketing droid [1] would call) the junk bin. 
>
>   
Same here - people throw out some decent crap. :)
I got a system fully loaded - CD burner and all - I ran a Linux firewall 
on it for a few years
back in the dialup days.

The USB 1.01 standard really sucked.  I think they were mainly competing 
with Apple
to get something out there.   I gave up on my motherboard USB's as well, 
added
a cheap USB 2.0 card - bingo!  Speed increase (about 25MB/sec transfer 
rate). 
The other reader I had was 1.0,and was really slow (1MB/sec), this new 
one is 2.0.
Worth the $20.

> George> If you have only one USB storage device at a time, then it
> George> make sense to just remove and reload the module.
>
> Right.  I'll do that and see what the "new" P4 with Slack 12.1/2.6
> kernel does.
>
>   
You'll like 2.6.  I find it much more smoother and seems to a bit more 
responsive.
Also, a lot of the old scheduling issues were addressed from 2.4, so 
preemptive mode
works much better.



Rich



More information about the nSLUG mailing list