[nSLUG] External hard drive problems

Vikram Chhatre crypticlineage at gmail.com
Wed Mar 12 16:23:23 ADT 2008


I am having problems using my Seagate 250GB external USB hard drive 
under Windows XP.  It has a single FAT32 partition and works flawlessly 
under Slackware.  When I plug it on Win xp machines (I have tried 3 so 
far), the system recognizes the drive and pops up several messages that 
a USB Mass Storage, Seagate Freeagent was recognized that the new 
hardware is now installed and ready to use.

However, the drive never shows up under My Computer.  When I tried: My 
Computer > Manage > Disk Management > the drive is listed as Basic 250GB 
FAT32 partition, but when I right click to assign it a drive letter 
manually, that option is disabled and the only active option in the menu 
is "delete partition".  What gives?  Exact same result on three 
different Win XP machines.

Is there a problem with file system?  Macintosh is yet another story.  
Mac won't even recognize the drive.  I thought Macs were able to read 
and write to FAT32 parititions?  I need to be able to use this drive on 
all three platforms.  Do I need another file system?

Alternatively, should I create two partitions and format one with EXT3 
for Linux, and another NTFS for Windows? 

Thanks
Vikram



More information about the nSLUG mailing list