[nSLUG] Card Reader

Rich budman85 at eastlink.ca
Sat Feb 9 01:06:53 AST 2008


Hi,

Anyone have issues trying to get card reader that supports the new SDHC 
format to mount?


Trying to get a ProFlash Card Reader 6-in-1 to mount under Linux.
I had no problem getting my older card reader to work, but since the
new camera uses a 4GB SDHC card, I needed to pick up a new reader.
(The camera connection works fine, just hate to waste the charged
battery).

It supposed to work like a pen drive.  When I connect, Linux does see
the device, assigns it uba1, however, when I try to mount as vfat, I
get the following error:

mount -t vfat /dev/uba /media/sd

mount: wrong fs type, bad option, bad superblock on /dev/uba,
       missing codepage or other error
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

The camera uses vfat fine when I connect it and mounts fine as well.
However, I found for some reason moving files from the camera doesn't
always work the best.  I've had a card get corrupted, which running
fsck.vfat on solved the issue and was able to recover all but 3 files
(never delete it until you fsck it).

lsusb
Bus 002 Device 006: ID 090c:6000 Feiya Technology Corp.

dmesg
usb 2-1: USB disconnect, address 5
usb 2-1: new full speed USB device using uhci_hcd and address 6
usb 2-1: configuration #1 chosen from 1 choice
 uba: uba1
usbcore: deregistering interface driver usb-storage
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev uba

Linux kernel 2.6.23.12

hal picked it up
 hald-addon-storage: polling /dev/uba (every 2 sec)

fsck.vfat /dev/uba
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
Got 0 bytes instead of 512 at 0

Just for the heck of it, I have a normal 1GB SD card.
Same thing.

The device is supposed to read SD/SDHC/MiniSD/MMC/MicroSD/RSMMC
I've tried it in other USB ports with same results.

I've been trying to find something about SDHC card readers in Linux,
but seems the docs have grown stale.  Many still mention usb devices
being treated as SCSI.

Any idea what I can check out or maybe resolve.
Is there a new module that may need to be loaded to deal with SDHC?



More information about the nSLUG mailing list