[nSLUG] Replaced CD drive - won't boot, won't play, players don't recognize

Robert Ashley rb.ashley at gmail.com
Tue Jul 31 16:54:56 ADT 2007


Hi Rich,

I tried your suggestion changing ...
>
>  Change   udf,iso9660 to  either  iso9660 or auto  (which is better), then
> the system will auto detect the file system type

like so...

bob at ashley:~$
/dev/hdc        /media/cdrom0   auto user,noauto     0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto     0

The drive seems to behave somewhat differently, the light coming on,
and the spin up/spin down over and over ceased, which, to me seemed
like progress. On a reboot, the machine seemed to think longer about
booting the cd, light on, consistent whirrr, and all that, so I was
half-excited. But alas, same result.

Then I tried taking the auto out and putting in iso9660.
/dev/hdc        /media/cdrom0   iso9660 user,noauto     0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto     0       0

Nada. I get this warning when trying Gnome's CDPlayer
/dev/cdrom does not appear to point to a valid CD device. This may be because:
a) CD support is not present in your machine
b) You do not have the correct permissions to access the CD drive
c) /dev/cdrom is not the CD drive.

Why does this refer to /dev/cdrom when all my refs keep the label
cdrom0 or cdrom1. I have no such place called /dev/cdrom, but I do
have /dev/cdrom1.

Well, at least your suggestion sounded good, and I was getting ready
to get my beer money out to buy you one!

Bob



More information about the nSLUG mailing list