[nSLUG] Optware Apache Zombie Process Issue

sknauert at wesleyan.edu sknauert at wesleyan.edu
Thu Jul 19 02:38:21 ADT 2007


Sorry if this isn't the right place, but most optware questions seemed to
be posted here. Anyway...

I did an SD mod on my WRT54GS, added a 1GB card and want to run apache.

I made a 256MB /opt directory and tried the optware install instructions
here http://www.nslu2-linux.org/wiki/Optware/OpenWRT-brcm24Build but the
links seemed dead.
Since the work on the OpenWRT port is in the dd-wrt feed, I went to dd-wrt
and followed their instructions here
http://www.dd-wrt.com/wiki/index.php/Optware which did seem to work.

I installed apache, but when it runs all the httpd daemons become zombie
processes and I can't see any web pages. (I set the servername, changed
the group, tried port 80, 8000, all the config issues that seemed to pop
up)

I installed mini-httpd (OpenWRT stock) and was able to see test pages so I
know that there are no port or firewall issues with the router (i.e. its
blocking port 80 to 192.168 hosts for some reason).

I also tried adding a 128MB swapfile since maybe apache was eating all the
router's memory. The GS has 32MB so I didn't think plain apache would be
an issue, but it didn't touch the swap.

Anyway... I'm basically stumped. Any ideas would be helpful.




More information about the nSLUG mailing list