[nSLUG] Re: Non-install stuff that fits installfest lessons

Rich budman85 at eastlink.ca
Thu Jan 18 14:36:44 AST 2007


On Thu, 2007-01-18 at 13:39 -0400, Mike wrote:
> me> Well, I'd like to see how someone cleverly and quickly gets
> me> ZoneMinder running under Slack 10.1.  I keep bumbling along.......
> 
> Rich> This is cool, I saw this when it was in it early stages.  Making
> Rich> motion detectors sampling image comparison.
> 
> Yeah, it is.  The "motion" program does the image comparison thing,
> too, and I've had that running fine.  ZoneMinder also has controls for
> tilt/pan/zoom of a more advanced surveillance cam over HTTP via a
> browser.
> 

Sounds nice. :)

> > Is there a particular problem you are having?
> 
> The author has only run this on RH.  Another guy has a HOWTO on
> porting to Slackware but it's old.  I'm porting to Slack 10.1.  I
> never used MySQL before and ZoneMinder requires it so I had to get
> that up and configured suitably.  

mysql is very easy to setup (chmod u+x /etc/rc.d/rc.mysqld, it uses the
mysql user/groupid, might need to set a pass for mysql) - as long as the
package was installed, or if you want a newer version.  slack 10.x has
the recent versions, anything older you may want to update the packages.
I think its version 5 now. I configured my data share to be in a
different location than /var/mysql - so this way when updating future
slacks it won't get accidentally wiped. :)  (happened one time...  long
time ago.. backups came in handy)


> Various other details, including documentation omissions in mplayer (for testing the 2nd-hand cam, not
> for part of ZoneMinder) have led me astray.

mplayer can be tricky to compile by hand.  All the libs must be in
place.  AVI's really sux system resources.  I hate them, but the
Microshaft world loves them.  WMV's are just as bad.  

when I get lazy.. I check for pkgs on http://www.linuxpackages.net/
they work 99% of the time.  sometimes the pkg wasn't compiled with
specific options, or key files are missed in the tarball, which then I
track the source and compile for myself. :P  

I remember compiling XFree86 one time... man 15 hours on a 450Mhz!  hehe

Note:  If you update to slack 11.0 and use your own custom kernels.. its
okay to reboot, but don't run anything that uses the 3D modules for your
video card, or run mplayer (video4Linux modules), until you recompile
the kernel with the new gcc compiler.  Problem is the kernel will not
load any modules compiled using a previous version of gcc.  

I like to run Stellarium (an excellent astronomy program in Linux,3D,
constellations, plus other cool effects like horizons landscape, has a
dome mode as well for projectors), it crashed the system hard - not even
SYSRQ would respond.  Found out it was the modules.  Recompiling solved
all the issues.



> 
> Last thing was a problem with shared memory.  The docs mention shared
> memory problems but not, AFAICS, the particular one I hit.  I've been
> distracted by a router failure, cold weather and other stuff and
> haven't gotten back to it yet so I don't have that machine booted and
> can't give you word for word details.  RSN. :-)
> 

hmm..  not allocating enough?   Wonder why they don't write to a raw
device.  I remember a few graphics editing apps that had the option to
setup a raw mount (I think this worked with ram disks as well). 


> ZoneMinder isn't a monolithic executable.  It's a snarl of interacting
> ELFs, scripts, browsers and colaborations (e.g.with MySQL).
> 

Most graphix tools are a collaboration of binaries. Why reinvent the
wheel. :)


Rich


!DSPAM:45afbe367224920515402!




More information about the nSLUG mailing list