[nSLUG] Machine Freezes on PCMCIA Card Insertion

Rich budman85 at eastlink.ca
Wed Feb 21 19:59:18 AST 2007


On Mon, 2007-02-19 at 22:58 -0800, Brandon W. Uhlman wrote:
> Hey, all.
> 
> At my job here in BC, we recently came across a small crate of old  
> Gateway laptops (mid-level P3s) that used to be part of a travelling  
> lab, and I decided to bring one home and see if I couldn't get Linux  
> running on it, which I did fairly successfully.
> 
> The only problem I've run into is with the PCMCIA wlan card I'm using,  
> a Linksys WPC11 (V1), which uses the hermes drivers from the kernel. I  
> was able to boot the machine once or twice with the wireless card in  
> it and use it succesfully, but now whenever I do, it freezes at the  
> time when it detects the card in the bootup sequence, or if the  
> machine is already started, it freezes immediately on insertion.
> 
> Nothing is recorded in the logfiles, and nothing strange looking  
> appears in the output of dmesg.
> 
> I'm running Gentoo, kernel 2.6.19.
> 
> Has anybody run into a similar problem at some point?

the hermes is only one of the required modules, the other two are ornico
modules. here is a good site that has a walk-thru (stated to work with
v2.0-v3.5) another option is using the NDISWRAPPER method (there is a
link on that site to use the dos drivers)

http://linux.oldcrank.com/tips/wpc11/


as for lockup, let me check if there is a way to black list a driver.
http://gentoo-wiki.com/Talk:HARDWARE_PCMCIA_NIC

do you know if the ornico and hermes are compiled into the kernel or
loaded as modules?  when the card is plugged in the hardware
autodetection service is trying to load something not there.  Most
likely, the ornico modules are not loaded at the time of the discovery.

do you have any info added to the etc/modules.conf file?
it may be better make a custom kernel compiling the hermes and ornico
drivers into the kernel.  I ran into similar issues with IDE controllers
disabling UDMA because of when the modules were being loaded. Compiling
into kernel solved the problem.  The only other option is to add kernel
options to load upon boot, but these sometimes get lost when doing
updates :)


Hope this helps

Rich

!DSPAM:45dcdcd641421899020048!




More information about the nSLUG mailing list