[nSLUG] copy/paste...web-->vim...unexpected results

Robert Ashley rb.ashley at gmail.com
Sun Feb 4 01:06:23 AST 2007


On 2/4/07, Rich <budman85 at eastlink.ca> wrote:

> What are you pasting - HTML code or just selecting displayed text, copy
> and paste?

 Just selecting displayed text to copy then paste (into vim).
>
> Displayed text may contain hidden characters, (char160) that may cause
> problems, also some embedded CSS codes may cause weird results.  Can we
> test the site name to test ourselves?

I tested your paragraph immediately above. See results below-->

> Do you have auto indenting or such enabled in vim?  Also, make sure you
> (O)pen a line, or set mode to (i)nput before pasting, otherwise your
> first couple characters might be interpreted as commands.

You solved it, Rich.  Here's results from 'normal' mode:

splayed text may contain hidden characters, (char160) that may cause
> problems, also some embedded CSS codes may cause weird results.  Can we
> test the site name to test ourselves.

First 3 characters gone, the '>',  the 'space', and the 'D'.

However, going to INSERT mode, 'i',  gives:
> Displayed text may contain hidden characters, (char160) that may cause
> problems, also some embedded CSS codes may cause weird results.  Can we
> test the site name to test ourselves?

And all is well that ends well.... Thanks for the solution, Rich.

Well....erm...almost well.  I'd like to do this in the console.  It
looks like I have to enable the mouse in the console environment
somehow??? Or is there a keyboard solution?

Bob

!DSPAM:45c569d2268468827987566!




More information about the nSLUG mailing list