[nSLUG] Problem with XFCE

Jack Warkentin jwark at eastlink.ca
Thu Aug 30 22:32:28 ADT 2007


Hi Everybody

I have tried very hard to try out XFCE 4.4, with very limited success.

I am running Ubuntu 6.06/Dapper Drake and XFCE 4.4 is not available
with that version. So I tried adding the Debian Testing lines to the 
sources.list and discovered that this does not work - there is some 
incompatibility between the Ubuntu and Debian archives.

I then read that MEPIS 7.0 was going to revert to being Debian-based. 
(See http://www.desktoplinux.com/news/NS6170488551.html). In fact, I 
have discovered many of the problems for myself that have lead Warren 
Woodford to take the decision to revert.

So I installed 7.0 Beta and had some problems getting my wireless card 
working. At first the Ralink RT2500 driver was not available, and 
when it was, neither the MEPIS network assistant nor Network Manager 
were able to configure it. However, I know how to configure my 
wireless card manually on Debian-based systems so had no trouble once 
I abandoned the configuration "goodies" provided by MEPIS.

But I really like the fact that the absolutely latest ATI fglrx driver 
(less than a month old) was available, and that Firefox came with the 
Adobe 9 Flash plugin - and this on an AMD64 system. It looks like 
they have put several wrappers around the 32-bit Flash so that it is 
usable on 64-bit Firefox.

However there is a problem with XFCE 4.4 - I have the window manager 
and panel installed, and one or two other components, but the 
packages providing the menu and the file manager will not install 
without removing libfam0. So I will have to wait for that to be fixed 
before I can really try it out.

One thing I really *really* don't like is, there seems to be a max of 
15 hard disk partitions now in force with the 2.6.22 kernel. Is this 
an absolute limit or is there a way of getting around it?

Thanks for the response.

Jack

On Tuesday 31 July 2007 00:50, Rich wrote:
> 
> Jack Warkentin wrote:
> > So I tried XFCE which appeared to be much "lighter weight" than
> > either KDE or Gnome and I preferred it to both Gnome and KDE.
> > However, I discovered several times that one of its components
> > created a runaway process (I am using Ubuntu 6.06/Dapper Drake and
> > the XFCE version is 4.3.0-0ubuntu1). So I reverted back to KDE.
> > Has anyone else come up against this problem with XFCE?
> >
> >   
> 
> Hi Jack,
> 
> You were using an old version of XFCE.  The recent 4.4 version
> really rocks. Desktop icons (except icon contents like images or
> such, I think that is in next release) and udev device icons
> 
> This version fixed quite a few issues.  I had 4.2, and tried using
> it, but found some short comings for what I do. 
> However, I've been using 4.4 for a few months now, and it is very 
> solid.  There was a problem with cairo libs,
> but that was more Slackware 12.0 related. 
> 
> I hit my system pretty hard, and I noticed Gnome w/Dropline 2.16 
wasn't 
> helping, it was getting slower and slower.
> So I decided to try XFCE 4.4.  I originally compiled it by hand, and 
had 
> it working, except overlooked an important python lib.
> This caused me some headaches once I traced it down (not well 
> documented).   However, around that time, Slackware 12.0 had  it 
compiled,
> and working.  So I tried the Slack 12.0 packages and it worked fine, 
> except Amarok was not configured for postgres - so I had to 
recompile.
> Other than that, its been very solid and fast.  I was running a 
resource 
> hungry java client, which ran better under XFCE.
> 
> I also gave Kde 3.5 a whirl to see how much has changed over the 
years. 
> I normally don't bother swapping desktops on the fly.
> I tried it, and turned off all the fancy animations to gain the 
speed it 
> was sucking up.   I feel Kde and Gnome are trying to be Win XXX look 
> alikes..  which in my mind is the wrong direction to take.  Make it 
> easy, but don't stop or rollback innovation just because Microslop 
says 
> so.  
> 
> I'm now back on XFCE.
> 
> I found a PC for sale, 64-bit 500MB Ram, 60GB hdd w/WinXP, and DVD 
> burner + monitor for $200. :)
> I yanked the drive and stuck it in my son's pc, because he won't 
migrate 
> to Linux.. I tried and pat him on the head when he whines about 
spyware 
> and adware flooding his system. I tell him here is the install 
disk - 
> have fun.   :)    I later installed a 75GB drive with Slack 12.0 for 
my 
> wife.
> She's one happy camper now.  She was running a K6-III 450 w/320MB 
RAM.  
> The machine was almost 10 years old. :)
> She tried XFCE, but got used to Nautilus... ugh.. I do not like 
Nautilus 
> either.  So I installed Dropline 2.18 beta now, she is running fine 
now.
> 
> So I found, XFCE is not for everyone.  My wife uses her desktop 
folders 
> in ways I've never bothered to.
> I just use a file manager or cmd line for that.. call me lazy... :)
> 
> 
> See if you get a more recent version of XFCE. Its worth it.
> 
> 
> Regards
> Rich
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/cgi-bin/mailman/listinfo/nslug
> 
> 

-- 
Jack Warkentin, phone 902-404-0457, email jwark at eastlink.ca
39 Inverness Avenue, Halifax, Nova Scotia, Canada, B3P 1X6



More information about the nSLUG mailing list