[nSLUG] USB drive fails e2fsck on startup

David Payne david at payneful.ca
Sun Aug 5 20:47:27 ADT 2007


On Sun, Aug 05, 2007 at 07:43:45PM -0300, David Payne wrote:
> Hi,
> 
> I recently installed Arch Linux but I ran into a problem. I 
> have an external USB hard drive /dev/sdb with thiree ext3 
> partitions /dev/sdb1-3.  If I add it to /etc/fstab with 
> default options on boot it complains that e2fsck fails and I 
> have to type my root password to "fix" it.  I comment it out 
> of /etc/fstab and boot as normal.  After I boot I run e2fsck 
> on the partitions it comes up clean.  A also mount them 
> using the mount command and it has no problems with that 
> either.  I can read/write to all my files.  I don't think it 
> can see the drive at the point in time where it trys to 
> check the disks on startup.  What can I do to get it to 
> mount on startup?
> 
> Thanks,
> 
> David Payne

Hi,

You can disregard this post.  I solved my problem.  I did 
what it says on this wiki:

http://wiki.archlinux.org/index.php/Using_udev_to_map_multiple_entries_to_a_device

It now seems to work.

Thanks,

David Payne



More information about the nSLUG mailing list