[nSLUG] Replaced CD drive - won't boot, won't play, players don't recognize

Robert Ashley rb.ashley at gmail.com
Wed Aug 1 00:24:29 ADT 2007


Rich,

Gotta hand it to you, Rich, you're as tenacious as a terrier!  Okay,
I'm following instructions.

Rich rote:
>  Try with auto again, and then try

Here confirms the change:
# /etc/fstab: static file system information.
/dev/hdc        /media/cdrom0   auto user,noauto     0       0

Rich rote:
>  mount -a      once the CD is in the drive ( are you trying to mount an
> audio CD or a data CD - like the Linux install CD? )

Yup, an audio CD.  It spins but no output. Then a data CD. It powers
up for 4 or 5 secs, stops, powers up, stops, powers up, stops...ad
infinitum. Light blinks on (1/2 sec) at onset of power, then blinks
off.

I had a hunch you were scratching your head on this "auto" thing,
wondering why it didn't work. I decided to switch physical drives
again, back to the original unit.

Well, lo!! A data CD, a photo album archive, worked perfectly!! Woo hoo!!

Now, inserting an audio disk prompts an audio disk icon to appear on
the desktop, something that wasn't happening before! I was hopeful,
but unfortunately, the Gnome CDplayer wouldn't recognize it. Using
cdtools in the console, I could get the cddrive to play, pause, stop
and eject, but no sound.

I tried a different data CD I had burned awhile back. Worked perfect.
Then I tried an Ubuntu disk (new), included in the last issue of Linux
World (User?).  Nothing, nada, rien.

Rich rote:
>  mount /dev/hdc  /media/cdrom0

Here's the result:
ashley:/home/bob# mount /dev/hdc  /media/cdrom0
mount: you must specify the filesystem type

Rich rote:
>  Also, try    cd /dev
>  ls -al cd*

Here's the result
lrwxrwxrwx 1 root root 3 2007-07-31 23:53 cdrom1 -> hdc

Rich rote:
>  and
>
>  ls -al hd*
>  to see your perms on these devices
>  paste the output here

Here's the result:
ashley:/dev# ls -al hd*
brw-rw---- 1 root disk   3, 0 2007-07-31 23:53 hda
brw-rw---- 1 root disk   3, 1 2007-07-31 23:53 hda1
brw-rw---- 1 root disk   3, 2 2007-07-31 23:53 hda2
brw-rw---- 1 root disk   3, 5 2007-07-31 23:53 hda5
brw-rw---- 1 root cdrom 22, 0 2007-07-31 23:53 hdc

>
>
>
>  Then I tried taking the auto out and putting in iso9660.
> /dev/hdc /media/cdrom0 iso9660 user,noauto 0 0
> /dev/scd0 /media/cdrom1 udf,iso9660 user,noauto 0 0
>
> Nada. I get this warning when trying Gnome's CDPlayer
> /dev/cdrom does not appear to point to a valid CD device. This may be
> because:
> a) CD support is not present in your machine
> b) You do not have the correct permissions to access the CD drive
> c) /dev/cdrom is not the CD drive.

Rich rote:
>  :) hehe  drat...  the only thing I could drink was Guiness and even that
> was watered down...
>  Either I got use to drinking real beer in the Maritimes, or the US beer was
> always crap. hehe

A round of watered down Guiness, for the man, Rich!

Bob



More information about the nSLUG mailing list