[nSLUG] rsync - remote box insists on root password

Bill Davidson billdavidson at eastlink.ca
Mon Apr 2 11:24:07 ADT 2007


Hi:

When you started rsync as a daemon on the remote machine, did you do
anything on the local machine to tell it to connect to the daemon rather
than using ssh?  As I understand it, in order to connect to an rsync
daemon you need to either use a double colon to separate the host part
from the path (like "rsync <ipnum>::/remote/path") or use an "rsync://"
URL (like "rsync rsync://<ipnum>/remote/path").  Of course, in either
case "remote/path" should be replaced by a module name defined in the
rsyncd.conf file.

So if your description is accurate I don't think you ever actually
connected to the rsync daemon, so in all cases you were connecting via
ssh.  So then the question becomes why ssh is asking for the root
password instead of your password.  You clearly can ssh into the remote
machine OK, since that is how you started the rsync daemon.  Exactly
what happens when you try this?  Can you cut and paste your command line
and the response (feel free to edit details like IP address)?  Is there
anything useful in your logs, on either machine, from either rsync or
ssh?

Where do you need to use sudo, other than in starting the daemon
process?

On Sun, 2007-04-01 at 00:10 -0300, Miles Thompson wrote:
> When establishing an rsync connection between a local machine and a machine 
> addressed by an URL, the remote machine insists on the root password. Both 
> systems are ubuntu, so I have to "sudo rsync..."
> 
> I have set myself up with admin privileges on both machines, yet no matter 
> what is tried, the remote machine always prompts for its root password.
> 
> What been tried thus far:
> rsync <ipnum>:/remote/path/   /local/path
> rsync //<ipnum>:/remote/path/   /local/path
> 
> rsync as a daemon on the remote machine, through SSH, before executing 
> either of the above:
> sudo rsync --daemon
> 	then tried both of the above
> 
> For the daemon, the remote rsyncd.conf file
> holds my username as the only authorized user, and my user/pass is stored 
> in the secrets file.
> 
> I also tried it with "use chroot = yes", and "use chroot = no" in rsyncd.conf.
> 
> Eventually I bowed to the remote box's insistence and used its root password.
> 
> Anyone done it without supplying that root password?
> 
> Regards - Miles Thompson
> 
> 
-- 
Bill Davidson <billdavidson at eastlink.ca>

!DSPAM:46111209160804904951218!




More information about the nSLUG mailing list