[nSLUG] rsync - remote box insists on root password

George N. White III gnwiii at gmail.com
Sun Apr 1 08:32:43 ADT 2007


On 4/1/07, Miles Thompson <miles at allnovascotia.com> wrote:

> When establishing an rsync connection between a local machine and a machine
> addressed by an URL, the remote machine insists on the root password. Both
> systems are ubuntu, so I have to "sudo rsync..."
>
> I have set myself up with admin privileges on both machines, yet no matter
> what is tried, the remote machine always prompts for its root password.

I use rsync for files owned by "me" with ssh and keychain, but I haven't used
a "sudo rsync".  The rsync daemon isn't installed on our legacy unix machines.
It is not uncommon to make root access more "difficult" to discourage
excessive use
of root but usually you can override such settings with configuration changes.

> What been tried thus far:
> rsync <ipnum>:/remote/path/   /local/path
> rsync //<ipnum>:/remote/path/   /local/path
>
> rsync as a daemon on the remote machine, through SSH, before executing
> either of the above:
> sudo rsync --daemon
>         then tried both of the above

If the rsync daemon has to be started for each session then rsync via
ssh takes fewer steps.

> For the daemon, the remote rsyncd.conf file
> holds my username as the only authorized user, and my user/pass is stored
> in the secrets file.
>
> I also tried it with "use chroot = yes", and "use chroot = no" in rsyncd.conf.
>
> Eventually I bowed to the remote box's insistence and used its root password.
>
> Anyone done it without supplying that root password?
>
> Regards - Miles Thompson

Have you tried keychain?
<http://oceanpark.com/notes/howto_ssh_keychain_public_key_authentication_forwarding.html>

-- 
George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

!DSPAM:460f985e3273700612134!




More information about the nSLUG mailing list