[nSLUG] rsync - remote box insists on root password

Miles Thompson miles at allnovascotia.com
Sun Apr 1 00:10:59 ADT 2007


When establishing an rsync connection between a local machine and a machine 
addressed by an URL, the remote machine insists on the root password. Both 
systems are ubuntu, so I have to "sudo rsync..."

I have set myself up with admin privileges on both machines, yet no matter 
what is tried, the remote machine always prompts for its root password.

What been tried thus far:
rsync <ipnum>:/remote/path/   /local/path
rsync //<ipnum>:/remote/path/   /local/path

rsync as a daemon on the remote machine, through SSH, before executing 
either of the above:
sudo rsync --daemon
	then tried both of the above

For the daemon, the remote rsyncd.conf file
holds my username as the only authorized user, and my user/pass is stored 
in the secrets file.

I also tried it with "use chroot = yes", and "use chroot = no" in rsyncd.conf.

Eventually I bowed to the remote box's insistence and used its root password.

Anyone done it without supplying that root password?

Regards - Miles Thompson


-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 268.18.23/740 - Release Date: 3/30/2007 1:15 PM



!DSPAM:460f28ee285681444715577!




More information about the nSLUG mailing list