[nSLUG] lost user access in most distros

rejean chamberland laudire2you at yahoo.ca
Wed Sep 20 20:15:46 ADT 2006


did it "again" and it worked rich. Yippee! I'm still pondering why it is that I had to "userdel" and "chmod u+s /bin/su* ( logging in as "root" ) and accepting to save the changes upon login out.
I'll move to OpenSuSE 10.1 tomorrow ( knowing that it will be a different experience; according to a different message I kept getting while booting into it or  Zenwalk or Ubuntu among others.
Thanks again everyone ( I will print the whole thread ) and don't mind me if I come back in a day or two. Please... 

Rich <budman85 at eastlink.ca> wrote: On Wed, 2006-09-20 at 12:38 -0400, rejean chamberland wrote:
> Hi Bill!
> Most of your questions are similar to the ones I was asking myself. I
> did assume that "userdel jeanre" had worked since it was followed by a
> clean prompt ( meaning no messages ).
> So I switch back to root again and "userdel jeanre". I switched back
> into rejean and now I get:
> [code]
> [rejean at localhost ~]$ su
> Password:
> su: cannot set groups: Operation not permitted
> [rejean at localhost ~]$ ls -l /bin/su*
> -rwsr-xr-x  1 501 root 20308 Aug 18  2005 /bin/su*

this is still a problem - as root run:   
   chown root /bin/su

the 501 is nobody - it needs to be root
then you should be okay




> [rejean at localhost ~]$
> 
> [/code]
> I'm definitely gonna check for rootkit because I don't want to spend 2
> days or a week fixing the other 7 corrupted distros to have the
> problem reoccuring again.
> If anyone else as a suggestion just shoot. I'm desperate here.





_______________________________________________
nSLUG mailing list
nSLUG at nslug.ns.ca
http://nslug.ns.ca/cgi-bin/mailman/listinfo/nslug





 		
---------------------------------
Now you can have a huge leap forward in email: get the new Yahoo! Mail. 

!DSPAM:4511cba441946079690500!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/mailman/private/nslug/attachments/20060920/e24672ad/attachment-0002.html>


More information about the nSLUG mailing list