[nSLUG] lost user access in most distros

rejean chamberland laudire2you at yahoo.ca
Wed Sep 20 10:22:47 ADT 2006


Here is an update;
 1. jeanre [b]was[/b] my temporary user. 
 2. I recreated rejean and "userdel" jeanre.
 3. Now when I am as rejean I try;
 [rejean at localhost ~]$ su
 Password:
 su: incorrect password
 4. so following some advice I booted into runlevel 1 and retyped my password.
 5. It was accepted but upon rebooting in runlevel 5 I still get the same problem. Part of it must be;
 [rejean at localhost ~]$ ls -l /bin/su*
 -rwxr-xr-x  1 jeanre root 20308 Aug 18  2005 /bin/su*
 [rejean at localhost ~]$
 
 6. So I/ll try switching user to root and see what "chmod u+s /bin/su* can do. 
 Will keep you posted.
 Thanks again rich
  
Rich <budman85 at eastlink.ca> wrote: On Tue, 2006-09-19 at 23:56 -0400, rejean chamberland wrote:
> Hi Rich!
> 

>         when I tried it in mandriva I got:
>         
>         [jeanre at localhost ~]$ su
>         Password:
>         su: cannot set groups: Operation not permitted
>         [jeanre at localhost ~]$
>         

Ok, I saw this long time ago, did a search on google to get a reminder.

Could be a few things:

1) run the 'groups' command to see what groups your id belongs to
       old versions used to use 'wheel' group for su access
       I think its no longer used.

2) check the permissions on the su command
       ls -l /bin/su*
   hopefully, the SUID bit is set 
   if not then run "chmod u+s /bin/su"  as root
   should be something like:
       -rws--x--x  1 root bin 37655 2006-03-24 15:39 "/bin/su"

Was anything recently installed or upgraded on your system?

What happened with the temp userid ?


Regards,
Rich


 		
---------------------------------
All new Yahoo! Mail  
---------------------------------
Get news delivered. Enjoy RSS feeds right on your Mail page.

!DSPAM:451140ad12852142660548!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/mailman/private/nslug/attachments/20060920/f9d9a100/attachment-0002.html>


More information about the nSLUG mailing list