[nSLUG] big problems with Ubuntu

billdavidson at eastlink.ca billdavidson at eastlink.ca
Mon Sep 18 17:41:00 ADT 2006


Hi:

On Mon, 18 Sep 2006, ricardd at mathstat.dal.ca wrote:

> When the system is hung up, I can use Alt-F1 and get a login prompt. After
> I login, I get the "-bash: /dev/null: Permission denied" error until I
> Ctrl-C.
>
> I logged in with the normal user because Ubuntu grants root privileges to
> the user and I use sudo to perform admin tasks.

Well, it seems like Ubunto *doesn't* grant you root privileges, or you 
wouldn't get permission errors. 
>
> ls -l /dev/null returns this:
>
> crw------- 1 root root 1, 3 2006-05-30 22:15 /dev/null

That is obviously incorrect, it should be world readable and writeable.

> To get eth0 running (apologies for how stupid I must be on this) I tried:
>
>> sudo ifup eth0
>
> but I now realise that this is probably not the right way to do this.

"ifup" is probably just a script, and you should be able to find it, read 
it, and figure out how to run the same comands from the prompt.  However, 
if we assume that you are using DHCP to acquire a netqork address, then 
just "modprobe eth0" to make sure the driver is loaded, followed by 
"/sbin/dhcpcd -t 60 -d eth0" should work, or at least give you some error 
messages.

> The last modififcations in /etc/udev/rules.d are from May, so it doesn't
> seem to have been changed this weekend. What really puzzles me is that the
> following entry from /etc/udev/rules.d/40-permissions.rules seems right:
>
> KERNEL=="null", MODE="0666"
>
> yet, /dev/null/ doesn't have 666 permissions.

Hmm...  so is udevd actually running?

> Another thing, I tried "sudo /etc/init.d/udev restart" and I get the
> following error message:
>
> /etc/init.d/udev: line 89: /sbin/udevplug: Permission denied
>
> The same error message appears during the booting and the permissions on
> udevplug are:
>
> ?rwxr-xr-x 1 root root 59018 May 22 11:25 /sbin/udevplug

I don't know what udevplug is, it isn't present on my Slackware system 
running udev.  But what is that first character in the ls output saying? 
Is it possible that that file is somehow missing or damaged?

> So there seems to be a bunch a files with screwed up permissions.

Well, the permissions on /sbin/udevplug look OK, but the file type seems 
strange, and you shouldn't be getting a "Permission denied" error when you 
try to run it.

Wish I could be more help.


-- 
Bill Davidson
billdavidson at eastlink.ca


!DSPAM:450f045d239761051881520!




More information about the nSLUG mailing list