[nSLUG] big problems with Ubuntu

Gerard MacNeil aa030 at chebucto.ns.ca
Mon Sep 18 17:35:26 ADT 2006


On Mon, 2006-09-18 at 16:58 -0300, ricardd at mathstat.dal.ca wrote:

> When the boot sequence stalls, the last message from the system is
> "Loading nvram module". However, this doesn't seem to be the cause of the
> error because when I boot in single-user mode I'm able to get a root
> prompt.

It sounds like a program needs to be run suexec is running in userland

> 
> When the system is hung up, I can use Alt-F1 and get a login prompt. After
> I login, I get the "-bash: /dev/null: Permission denied" error until I
> Ctrl-C.

I got that at different times.  Something in .bashrc complaining that it
cannot redirect to the non-existent /dev/null.  

> To get eth0 running (apologies for how stupid I must be on this) I tried:
> 
> > sudo ifup eth0

Actually, a very good way to run the command. Unfortunately if the
device does not exist, the kernel loader will not load the device code
to support your card.

> Another thing, I tried "sudo /etc/init.d/udev restart" and I get the
> following error message:
> 
> /etc/init.d/udev: line 89: /sbin/udevplug: Permission denied

I don't have a /sbin/udevplug ... I run Debian Sid

Asking Google, it replied with a "Hang while booting" reference at 
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.15/+bug/32597

Verbose discussion, that.  One thing to note:
[QUOTE}

One more observation: I did the following which seems to fix things
(mostly -- it still happens sometimes but not so often)

(1) comment out the udevplug lines from /etc/init.d/udev
(2) Create /etc/init.d/udevplug with *just* the udevplug lines in
"start)" and nothing in the other sections
(3) Symlink this as /etc/rcS.d/S99udevplug (so it's the last thing to
start in runlevel 1)
[/QUOTE]




!DSPAM:450f0310238591272011805!




More information about the nSLUG mailing list