[nSLUG] big problems with Ubuntu

ricardd at mathstat.dal.ca ricardd at mathstat.dal.ca
Mon Sep 18 16:58:31 ADT 2006


Hi Bill,
I agree that reinstalling is the wrong way to fix a problem and I am
trying to avoid it at all costs. However, there is a point where I run out
of ideas and know-how to fix problems and reinstalling is unfortunately
the only alternative left. Let's hope that I can fix this one without
reinstalling.

When the boot sequence stalls, the last message from the system is
"Loading nvram module". However, this doesn't seem to be the cause of the
error because when I boot in single-user mode I'm able to get a root
prompt.

When the system is hung up, I can use Alt-F1 and get a login prompt. After
I login, I get the "-bash: /dev/null: Permission denied" error until I
Ctrl-C.

I logged in with the normal user because Ubuntu grants root privileges to
the user and I use sudo to perform admin tasks.

ls -l /dev/null returns this:

crw------- 1 root root 1, 3 2006-05-30 22:15 /dev/null

To get eth0 running (apologies for how stupid I must be on this) I tried:

> sudo ifup eth0

but I now realise that this is probably not the right way to do this.

ifconfig only shows "lo" and not "eth0"

Regarding the updates, it is really a mystery to me since my machine was
up and running on Saturday. I can't recall exactly what the updates were
but it is very likely that some of them took effect on reboot (i.e this
morning).

The last modififcations in /etc/udev/rules.d are from May, so it doesn't
seem to have been changed this weekend. What really puzzles me is that the
following entry from /etc/udev/rules.d/40-permissions.rules seems right:

KERNEL=="null", MODE="0666"

yet, /dev/null/ doesn't have 666 permissions.

Another thing, I tried "sudo /etc/init.d/udev restart" and I get the
following error message:

/etc/init.d/udev: line 89: /sbin/udevplug: Permission denied

The same error message appears during the booting and the permissions on
udevplug are:

?rwxr-xr-x 1 root root 59018 May 22 11:25 /sbin/udevplug

So there seems to be a bunch a files with screwed up permissions.

Thanks for the help.
Cheers,

Dan

****************************************************************************
[nSLUG] big problems with Ubuntu
billdavidson at eastlink.ca billdavidson at eastlink.ca
Mon Sep 18 15:46:36 ADT 2006

Hi:

On Mon, 18 Sep 2006, Daniel Ricard wrote:
> Hello,
>
> Until today, I was very happy with Ubuntu. However, I'm am now having
> problems that are beyond my understanding and I don't want to have to do
> another reinstall. I always seem to need 2 days to get everything back up
> and configured correctly, so if I can avoid that, it would be great.

Re-installing is, in general, the wrong way to fix a problem.  The better
way is to identify the problem, locate the source of the problem, and
correct it.

> I used my system over the weekend without a problem. When I turned my
> laptop on this morning, it would stay stuck near the end of the booting
> sequence.

At what point in the boot sequence did it hang?  What was it attempting to
do?  Did it produce any error messages?  Were syslogd/klogd running yet?
Is there anything in the system logs (/var/log/*) that indicate what the
problem might have been?  How long did it seem to hang?

> I then rebooted in safe mode and logged in using my usual user.
> After logging in, I got "/dev/null/ permission denied" messages in bash
> and had to Ctrl-C to get a prompt.

I presume "safe mode" is a Ubuntu-ism for single-user mode -- I have never
used Ubuntu.  Why did you log in as your usual user, as opposed to root?
If you need to do system maintenance you are generally going to need root
privileges.

What does "ls -l /dev/null" show?  Who owns /dev/null, and what
permissions are set on it?

> It now seems that the permissions on just about everything in /dev/ are
> wrong and I can't get xorg to go up, nor can I get eth0 to work. From what
> I gather from ubuntu mailing lists and forums, a problem with udev might
> be to blame. However, my system is completely up-to-date with
> respect to upgrades and such. The problem now is that I can't connect to
> the internet since eth0 is now working.

What did you do to try to get eth0 working?  Are the correct modules
loaded?  If you try to run ifconfig what happens?

More importantly, what changed between the system working on the weekend
and then not working?  Were any updates installed that might have taken
effect on reboot?  Look at modification times on any files having to do
with udev (on my system, under /etc/udev).  Or use find to locate all
files whose mtime is newer than, say, Friday.

I know it all seems like a mystery right now, but you need to provide some
more information.

>
> I am now at a stage where I do not know what to do to fix this. Again, I
> would really really like to avoid a reinstall. Does anyone have
> suggestions?
> Cheers,
>
> Dan
>
>
>
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/cgi-bin/mailman/listinfo/nslug
>
>
>


-- 
Bill Davidson
billdavidson at eastlink.ca





!DSPAM:450efa67231011966495762!




More information about the nSLUG mailing list