[nSLUG] debian 3.1 r3-i386

Ben Armstrong synrg at sanctuary.nslug.ns.ca
Sun Sep 10 11:45:00 ADT 2006


rejean chamberland wrote:
> Hi Jean-Paul and everyone else. I do not want klaptopdaemon. You are right I do not have a laptop but whenever I try "apt-get -f install" as suggested this is what I get.
> Here is a session as an example:
> [code]
> #apt-get install apt
> Reading package lists...done
> building dependency tree...done
> apt is already newest version
> You might want to run 'apt-get -f install' to correct these:
> The following packages have unmet dependencies:
> kdeutils:Depends:klaptopdaemon (>=4:3.3.3.2-1) but is not going to be installed.
> E:unmetdependency. Try "apt-get -f install with no packages (or specify a solution)
> [/code]
>   

That's one of the downsides of metapackages.  They are collections of a
large number of pieces of software, some of which you'll find useful,
and some not.

> When I do so I come back to the same message.
> Anyway. I managed to do "#tasksel install desktop" and did install a whole bunch of stuff. 

And that's one of the downsides of tasks.  The designers of tasks try to
put enough software in to meet a broad variety of user needs.  Tasks
don't have the flexibility of being tailored for the needs of specific
users.  So although you don't have a laptop, laptop software is included.

> However when I do "startx" I get:
> [code]
> Skipping "usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.0":No symbol found
> Skipping "usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.0":No symbol found
> Skipping "usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.0":No symbol found
> (EE)xf86OpenSerial:Cannot open device /dev/input/mice
>      No such device
> (EE)Configured mouse:Cannot open input device
> (EE)PreInit failed for input device "Configured Mouse"
> No core pointer
>
> Fatal server error:
> failed to initialized core devices
> [/code]
>   
At this stage your install has been aborted so you don't know what state
your system is in.  Probably lots of things are not installed yet due to
the corruption in the package that's failing.

> I have tried "xf86conf" I don't know how many times with a little variation here and there. I have "vi /etc/X11/XF86Conf" but I still get the same message whenever I try "startx".
> Any clue anyone?
>   

I wouldn't try to continue fixing the system here without first
addressing the aborted install.  Clearly the package is corrupt.  Either
remove the package (which means removing the things that depend on it)
or replace it with a good version.

But also, given this one package is corrupt, I'd worry about whether
your whole CD is good or not.  For all we know, other packages are
corrupt, too.  How did you get the CD?  Did you burn it yourself from an
iso?  Did you verify that the iso's md5sum matches the one published for
the image?  And even if the iso is fine, the burn itself might be bad. 
Did you verify the burn afterwards?

Finally, if it's not just you, I'd expect other users would have
complained by now about it.  Yet after a quick google I couldn't find
any relevant pages about your problem, which is what makes me suspect
it's just your copy that's corrupt.

Ben

!DSPAM:450424f0274491388021347!




More information about the nSLUG mailing list