[nSLUG] displaying graphics remotely via xterm

Jason Kenney jdkenney at gmail.com
Thu Jun 8 16:11:51 ADT 2006


Hi,

If your username and password were incorrect, that would be the error you'd
receive. I suggest deleting your ~/.Xauthority file (on your own machine,
but maybe the one on torch is messing with you) and trying again.

I just tried running matlab remotely from torch on my home machine, and it
worked fine, so I suspect it is either your .Xauthority causing trouble, or
you have something funky going on in your local ssh_config file (I'm on
ubuntu, and the only non-default option I changed was to enable
X11Forwarding).

I never bothered learning what .Xauthority was all about, but it's caused me
grief in the past, and the solution was always just deleting it. I think it
gets corrupted sometimes.

If this doesn't work, try running ssh with a bunch of -v flags, and you'll
likely be able to tell more exactly what went wrong.


Jason

On 6/8/06, Jack Warkentin <jwark at eastlink.ca> wrote:
>
> Hi Chris
>
> The command you used looks good. There are, however, two possible
> problems that I can see.
>
> 1. Your username/userid on torch.cs.dal.ca is different from that on
> your laptop. If that is the case use user at torch.cs.dal.ca where user
> is your username on the remote system.
>
> 2. The sshd daemon on torch.cs.dal.ca does not have X11 Forwarding
> enabled. See man 5 sshd_config. Usually this means changing the
> parameter of the X11Forwarding entry to Yes from No. However, If
> UseLogin is set to Yes then X11Forwarding will be disbled.
>
> Regards
>
> Jack
>
> On June 8, 2006 02:19 pm, Christopher Jordan wrote:
>
> > I forget how to do this. I want to run matlab in graphical mode from
> > my xterm off of my laptop. I seem to remember it goes along the
> > lines of:
> >
> > ssh -X torch.cs.dal.ca matlab
> >
> > but I am getting the following error:
> >
> > Warning: No xauth data; using fake authentication data for X11
> > forwarding.connect /tmp/.X11-unix/X0: No such file or directory
> > XIO:  fatal IO error 131 (Connection reset by peer) on X server
> > "localhost:90.0"
> >       after 0 requests (0 known processed) with 0 events remaining.
> >
> > Anyone know how to do this?
>
> Jack Warkentin, phone 902-404-0457, email jwark at eastlink.ca
> 39 Inverness Avenue, Halifax, Nova Scotia, Canada, B3P 1X6
>
>
>
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/cgi-bin/mailman/listinfo/nslug
>
> 
>
>


!DSPAM:448877ed91302121677620!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/mailman/private/nslug/attachments/20060608/5bf1bc79/attachment-0002.html>


More information about the nSLUG mailing list