[nSLUG] displaying graphics remotely via xterm

Mike Spencer mspencer at tallships.ca
Thu Jun 8 15:59:05 ADT 2006


Chris Jordan quoth:

> ssh -X torch.cs.dal.ca matlab
>
> but I am getting the following error:
>
> Warning: No xauth data; using fake authentication data for X11
> forwarding. [....]

Is it possible that you have to do "xhost +torch.ca.dal.ca"?

I just tried this, doing ssh -X to an Athena mit.edu host; doing xhost
+hostname on the local machine; then emacs & on the remote host's
command line.  Emacs started up okay in a new window on my home box.
(A little tedious waiting for X over ssh over dialup, so I didn't give
the connection a serious workout.)

I do have a /tmp/.X11-unix/XO file that's empty.  It's always there.
I never tried to figure out what it did or when.

Possible further help:

   man mcookie
   man xauth
   man xhost

"xauth -v list" might or might not offer some insight.


FWIW,
- Mike

-- 
Michael Spencer                  Nova Scotia, Canada       .~. 
                                                           /V\ 
mspencer at tallships.ca                                     /( )\
http://home.tallships.ca/mspencer/                        ^^-^^

!DSPAM:4488712088011812899119!




More information about the nSLUG mailing list