[nSLUG] Static IP woes

Donald Teed donald.teed at gmail.com
Tue Sep 20 14:41:33 ADT 2005


There are a lot of changes involved in what you are working on.
Without a picture of how it worked before, it is difficult to pinpoint
the most likely parts to have broken.

Connecting to your router's web page should show a status
page confirming if your static IP is assigned properly. Make
sure you don't get the internal LAN IP mixed up with the WAN IP.

Is there a DHCP server running by default on the router? That
can confuse clients if they should be getting their IPs
assigned from elsewhere.

Have you started to run your own DNS?
If so, test connectivity to the outside world by IP numbers first
to determine if DNS configuation is the real source of the breakdown.

Depending how you had the router and cable modem set up before,
the network cable might need to be a cross over cable between
the eastlink modem and your router box - I usually use whatever cable
the ISP gave me with the modem.

Also check your router firewall set up. If you turn it off briefly and 
discover
things work as they should, then that is the culprit. If the slackware
box is running iptables, try turning that off briefly as well and see if
something was badly configured.

If you don' t run the slackware box in a DMZ, you will need port forwarding
to allow DNS and other essential traffic to pass in. Make sure that is set 
up on the
router.

These are just some check list items I would normally go through
in this situation. You would know which ones really might apply.

The clients can tell you alot too. On the Windows box ifconfig /all
will show you the DNS, gateway, etc. it picked up.


On 9/20/05, Rowan Townshend <rtownshend at emslimited.ca> wrote:
> 
> Hello all,
> 
> I'm setting up a brand new server (running Slackware 10.1), and I
> planning on running all kinds of services through it (web, mail, DNS,
> etc...). So I told the higher ups that I would need a static IP to
> point all of this stuff at, out in the world. They got the static IP
> from Eastlink (the ISP for our office), and so far I have yet to be able
> to get the numbers to take without cutting access to the rest of the
> Internet for my office (including the router itself).
> 
> We run a wireless network in our office, the router is a Linksys 2.4
> GHz Wireless G (Model#: WRT54G) running the latest Linksys firmware.
> The server (Dell PowerEdge SC-1420) is connected with a length of
> networking cable to the router. Then a bit of network cable goes from
> the router to the cable modem Eastlink supplies (Motorola Surfboard).
> 
> Laying in the numbers (I confirmed them already with Eastlink) was a
> simple enough task, I even went looking to see if I missed anything (EG:
> 
> http://linksys.custhelp.com/cgi-bin/linksys.cfg/php/enduser/std_adp.php?p_faqid=709&p_created=1084219955&p_sid=5A4BMXPh&p_lva=&p_sp=cF9zcmNoPSZwX3NvcnRfYnk9JnBfZ3JpZHNvcnQ9JnBfcm93X2NudD0xMjY3JnBfcHJvZHM9JnBfY2F0cz0mcF9wdj0mcF9jdj0mcF9zZWFyY2hfdHlwZT1hbnN3ZXJzLnNlYXJjaF9ubCZwX3BhZ2U9Mw**&p_li=&p_topview=1)
> . No luck however. As soon as the info is put in, we lose the external
> connection (the internal LAN remains active.)
> 
> We have even tried a different router all together (SMC) and still no
> go with the same symptoms.
> 
> Has anyone on the list had similar troubles with Eastlink and Static IPs?
> 
> -Rowan Townshend
> 
> 
> 
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/cgi-bin/mailman/listinfo/nslug
> 
> 
> 
>


!DSPAM:433049cf106301199710236!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://nslug.ns.ca/mailman/private/nslug/attachments/20050920/99b60efe/attachment-0001.html>


More information about the nSLUG mailing list