[nSLUG] Chapter Three - Some HP Installation Progress.

robert ashley at chebucto.ca
Wed May 11 00:13:23 ADT 2005


On Tue, 2005-10-05 at 22:37 -0300, Jack Warkentin wrote:
> On Tue, 2005-05-10 at 21:40, robert wrote:
> 
> > checking for jpeg_set_defaults in -ljpeg... no
> > configure: error: "cannot find libjpeg support" 
> > configure: error: /bin/sh './configure' failed for prnt/hpijs
> 
> Here is what I did to troubleshoot this problem.
> 
> First, the 'lib' part of libjpeg looked like there was another missing
> library. Library files are stored either in /lib or /usr/lib. So I did a
> 
> find /lib /usr/lib -iname '*libjpeg*'
> 
> (as root) to try to find a file that would give me a place to proceed
> from. It turned up the following on my Libranet 2.8.1 system, which is
> Debian based.
> 
> /usr/lib/libjpeg.a
> /usr/lib/libjpeg.so.62
> /usr/lib/gthumb/modules/libjpegtran.so
> /usr/lib/libjpeg.so.62.0.0
> /usr/lib/libjpeg.la
> /usr/lib/libjpeg.so

Thanks for your time and effort in laying this out for me. I tried to
follow your train of thought, then replicate you actions.

# find /lib /usr/lib -name *libjpeg*

/usr/lib/libjpeg.so.62.0.0
/usr/lib/libjpeg.so.62

> So at this point it was almost certain that the missing library is
> libjpeg.so (since librairies have a .so extension. (I dismissed the idea
> of the gthumb possibility because that seemed to be too specific to the
> gthumb package, which is used to view digital images.)

gthumb not in my above list.

> Then I issued
> 
> dpkg-query -S /usr/lib/libjpeg.a
> 
> to try to find the package from which the above file was installed.
> 
> The response was
> 
> libjpeg62-dev: /usr/lib/libjpeg.a
> 
> Thus libjpeg62-dev might be the required package, but then again it
> might not. So I did a
> 
> dpkg-query -L libjpeg62-dev
> 
> to find out what all files were included in the libjpeg62-dev package.
> 
> It did not list all of those discovered by the 'find' command above so I
> tried

libjpeg62-dev and libjpeg.a are not in my list.

> dpkg-query -S /usr/lib/libjpeg.so.62

> which turned up
> 
> libjpeg62: /usr/lib/libjpeg.so.62

# dpkg-query -S /usr/lib/libjpeg.so.62

which turned up

libjpeg62: /usr/lib/libjpeg.so.62

> So now libjpeg62 might also be the required package.
> 
> Debian systems have a file /var/lib/dpkg/available that lists all Debian
> packages available using the sources set up for apt-get to use on each
> system. (There is also a file called /var/lib/dpkg/status that lists all
> of those actually installed.) Since there can be multiple versions of
> libraries I opened /var/lib/dpkg/available with less and searched for
> packages beginning with the name libjpeg. This is done (from within
> less) by issuing first
> 
> -i
> 
> which says to ignore case, and then
> 
> /^package.*libjpeg

Okay, good...

-i (within less)
/^package.*libjpeg

Package: libjpeg62

I'm pretty sure this was the only package to turn up. 

> which says to look for lines beginning (that's the ^) with 'package' and
> (after any other stuff, that's the .*) includes 'libjpeg'. This only
> turned up the two packages above. Which one do you need? Probably
> libjpeg62 because it is not statically linked.

Your troubleshoot steps and my replication of them appear to converge on
the identical result. That was neat!

> Also, I should point out that my installation is Woody-based and I
> believe you said yours was based on Sarge, so the specifics for your
> system may be slightly different.

One result (mine, sarge), instead of two (yours, woody)? 

> If you want to reduce the number of ./configure iterations that you have
> to go through in order to get all of the dependencies satisfied, but
> without resorting to just installing the binary package, you could fire
> up the Synaptic package manager and select the binary package that would
> be needed. This would give you a list of unsatisifed dependencies that
> would have to be satisfied. You could then install those all at once so
> as to short circuit some iterations.

If yours and my results pinpoint libjeg62, and if the latest config.log
indicates that this is the last of the ./configure stumbling blocks, are
the iterations possibly nearing their end? 

Thanks for taking me through this clear, systematic exercise, Jack. Do
you have a little teaching experience? (only joking!)

Are we winning?

Bob


!DSPAM:428178bb246601345092189!




More information about the nSLUG mailing list