[nSLUG] migrating to debian sarge

Donald Teed donald.teed at gmail.com
Sun Jun 12 09:13:32 ADT 2005


I have a server I'd like to migrate to debian from gentoo.
The game plan is to install debian on a regular linux partition (hdi11),
move my data and configs over to it, then recreate software raid
partitions and move debian over to it.

The first method I tried was the Debian sarge net install CD.
I booted from the CD.  I was installing to a fresh partition it had fdisked,
or whatever it uses. At about 50% of installing the base layout, there
is an error that
says something to the effect of my kernel is out of step with
the modules.conf, and I need to reboot "soon", but not immediately
since my installation isn't finished.  I figure this is just a warning
that would apply in circumstances other than the install, and try
to proceed.  No matter what option I picked in the next few installer
menu options, it always wanted to restart the base layout install part
at 0%, and bombed out with the same error at around 50%.

Next up: debootstrap.  I install it and apt-get in Gentoo, and
tell it to place sarge on /dev/hdi11.  That seems to work OK.  I chroot
into the new debian partition and set up a few packages from apt-get
run base-config, build my own 2.4.31 kernel from kernel.org.
Exit chroot, add an entry in grub.conf for the debian location.

Debian boots without error, but when it arrives at the point of
starting inits, it has errors.  This from daemon.log:

Jun 11 20:21:59 artistic lwresd[296]: starting BIND 9.2.4
Jun 11 20:21:59 artistic lwresd[296]: using 2 CPUs
Jun 11 20:21:59 artistic lwresd[301]: loading configuration from
'/etc/bind/lwresd.conf'
Jun 11 20:21:59 artistic lwresd[301]: none:0: open:
/etc/bind/lwresd.conf: file not found
Jun 11 20:21:59 artistic lwresd[301]: loading configuration from
'/etc/resolv.conf'
Jun 11 20:21:59 artistic lwresd[301]: no IPv6 interfaces found
Jun 11 20:21:59 artistic lwresd[301]: command channel listening on 127.0.0.1#953
Jun 11 20:21:59 artistic lwresd[301]: lwres listening on 127.0.0.1#921
Jun 11 20:21:59 artistic lwresd[301]: running
Jun 11 20:22:06 artistic rpc.statd[454]: Version 1.0.6 Starting
Jun 11 20:22:06 artistic rpc.statd[454]: statd running as root. chown
/var/lib/nfs/sm to choose different user
Jun 11 20:23:46 artistic init: Id "1" respawning too fast: disabled
for 5 minutes
Jun 11 20:23:46 artistic init: Id "2" respawning too fast: disabled
for 5 minutes
Jun 11 20:23:46 artistic init: Id "3" respawning too fast: disabled
for 5 minutes
Jun 11 20:23:46 artistic init: Id "5" respawning too fast: disabled
for 5 minutes
Jun 11 20:23:46 artistic init: Id "6" respawning too fast: disabled
for 5 minutes
Jun 11 20:23:46 artistic init: Id "4" respawning too fast: disabled
for 5 minutes
Jun 11 20:23:46 artistic init: no more processes left in this runlevel

dmesg is error free.

Googling for the errors on init doesn't show a solution or typical
cause for this.
I did see one other debian user that had an existing grub set up on his
MBR (as I did) and ran into this.  But I can't see how it could effect it.
We are way beyond the boot loader when this is going berserk.

!DSPAM:42ac26ec321259279585766!




More information about the nSLUG mailing list