[nSLUG] Re: X freeze, clock weirdness: Connected? Cause?

Mike Spencer mspencer at tallships.ca
Wed Jun 1 17:24:39 ADT 2005


Dop> It specifically sounds like the video card to me...badly
Dop> aligned backplane so the fingers wouldn't actually seat all the
Dop> way in.  Since you've tried a different video card, have you
Dop> tried it in a different slot...

Yes.

Dop>  ...and perhaps tried taking off the backplane to see if it
Dop> seats better?

Hmmm, no.  Okay. I'll try that.

Dop> ... board might have some of the flaky capacitors that were
Dop> around a few years ago...

Didn't look for that, either.

Dop> It might also be a good idea to try memtest86, cpuburn...

Hmm..  I don't seem to have those.  Are they part of a single package
or what?

Jason> ...if you are really sadistic you could see if this causes a
Jason> core dump, and if so, recompile X with debug info, and run gdb
Jason> on the core to see where it died.

I've done some C code and used gdb but I think it likely that hacking
a coredump may be beyond me.

Jason> A slightly less sadistic attempt would be to strace X:
Jason> 
Jason> ~/Xstracedir $ strace -f -ff -o Xtrace startx

Huh.  Didn't know about strace.  Did that. Got 1.4M of data.  I'll
grovel over it some more but I'm afraid I'm not knowledgeable enough
to know whether or not, f'rgzample,

    [pid  1268] open("/dev/mouse", O_RDWR|O_NONBLOCK) = 6
    [pid  1268] ioctl(6, SNDCTL_TMR_TIMEBASE or TCGETS, 0xbffff3fc) = -1 
                ENOTTY (Inappropriate ioctl for device)

is problematic when the xorg.log files appears to report mouse config
as successful.

Jason> Examining strace output is a bit a black art, you have to get a
Jason> feel for what is actually a problem, and is a reported error,
Jason> but not the one you're looking for.

Um, yes, I can see that. :-)

Jason> The main problem with stracing X will be the size of the files
Jason> produced I suspect.

The main problem appears to be that strace and X are both trying to
hack the hardware at the same time -- timers, interrupts, ioctls etc.
strace startx put the screen into a really weird mode recoverable only
by reboot but I still got the data because I did startx from a remote
login. 

Thanks for the advice.  Further comment welcome.  Time for me to take
a break from this and deal with my garden, now that the rain has
stopped.

- Mike

-- 
Michael Spencer                  Nova Scotia, Canada       .~. 
                                                           /V\ 
mspencer at tallships.ca                                     /( )\
http://home.tallships.ca/mspencer/                        ^^-^^

-- 



!DSPAM:429e18f6218361207586475!




More information about the nSLUG mailing list