[NSLUG] mplayer problem

Mike Spencer mspencer at tallships.ca
Tue Feb 22 04:29:14 AST 2005


I asked earlier about playing video on Linux and several replies
suggested mplayer.  Fetched mplayer, fetched codecs, compiled okay,
installed okay.

Runs but won't play video.  Numerous details follow in the hope of
some enlightement. 

Any suggestions welcome.

- Mike

---


Tried the infrared.avi file that Dop provided and a QuickTime .MOV
file.  With no explicit -vo <driver> option on the command line, X
puts up the ghost frame for a new window but when I click it into
place, it vanishes and I get:

   FATAL: Cannot initialize video driver.

   FATAL: Could not initialize video filters (-vf) or video output (-vo).

Using -vo xv, mplayer exits without trying to put up a window and I
get:

    It seems there is no Xvideo support for your video card available.
    Run 'xvinfo' to verify its Xv support and read DOCS/HTML/en/video.html#xv!
    See 'mplayer -vo help' for other (non-xv) video out drivers. Try -vo x11
    Error opening/initializing the selected video_out (-vo) device.

I have i810 on-mobo video.  The i810 chipset is said to support the
XVideo extension and my XFree86 log says XVideo is loaded (and doesn't
subsequently say it's disabled.) Other X apps work fine.  OTOH, xvinfo
says:

root# xvinfo

X-Video Extension version 2.2
screen #0
 no adaptors present


I've tried all the other -vo <driver> options that make any sense,
including VESA and SVGA (from both X and from console 2 with X up on
console 7).  None of them work. In one case, "-vo vesa" blanked the
screen and locked up the machine, forcing a powerdown to reboot.

The mplayer docs say to set up mtrr. I don't know what that is but I
have this:

bogus% cat /proc/mtrr

reg00: base=0x00000000 (   0MB), size= 128MB: write-back, count=1
reg01: base=0x07f00000 ( 127MB), size=   1MB: uncachable, count=1
reg02: base=0xd0000000 (3328MB), size=  64MB: write-combining, count=1


System details:

OS Release:  Linux 2.4.5 built with: gcc version 2.95.3 20010315

Distro:      Slackware 8.0

X:           XFree86 Version 4.1.0
             Logged warnings (WW):  Cannot open APM
             Logged errors (EE):    none

CPU:         PII (i686 with 399.76 BogoMips)

Video:       i810

RAM:         128M (sysinfo says 126M)

Compiler:    gcc 2.95.3



!DSPAM:421aeb7d39954477315454!




More information about the nSLUG mailing list