[nSLUG] Boot problem

Dop Ganger nslug at fop.ns.ca
Thu Jan 29 09:34:09 AST 2004


On Wed, 28 Jan 2004, Mike Spencer wrote:

> me> So I removed the [new Slak-8 install] HD from the P133 and put it
> me> into a PII (replacing another HD as hda).  Nothing I know how to
> me> do will get it to boot in the PII.
>
> Dop> The P133 is using a different addressing scheme from the PII, and
> Dop> the PII may be hitting the 512MB limit. Can you put a /boot
> Dop> partition on the drive somewhere before the 512MB limit?
>
> "Different addressing scheme", huh?  I better use that as a key phrase
> for further reading because I don't know about that.

OK, there should be 2 or 3 settings you can twiddle with in the BIOS; LBA
(logical block addressing), CHS (Cylinder/Heads/Sectors) and possibly
translated. One of these may be enough to get the drive working (after a
tedious process of booting off the rescue disk, running lilo, rebooting to
see if it's fixed), but I wouldn't count on it. This is how the BIOS
presents the drive to the bootloader, so the end result may be lilo
booting up and being unable to read the right sector.

The limitations are (and this is all rather hazy, so take it with a pinch
of salt) 512 meg for CHS, and 8 gig for LBA, unless you're doing LBA with
newer EIDE in which case it's 32 gig, at which point you need to stroke
the drive to read the data beyond 32 gig, unless you have a really new
EIDE which supports LBA > 32 gig in which case you're good to go up to a
terabyte (I think).

> But considering that the PII is the newest machine I have, both HDs are
> formatted as you suggest:
>
>          had1   linux swap  (128M?  I forget)
>          hda2   /boot       (small)
>          hda3   DOS16       (small)
>          hda4   /           (remaining space)

Hmmm... That *should* work quite happily...

> Dop> That may be enough to get it working (specially since you're using
> Dop> -l).
>
> Well, lilo worked on the P133 *without* -l or "linear" in lilo.conf.
> I tried -l from a floppy boot in response to the lilo error message.

OK. Try creating a boot disk based around the kernel you have installed.
Boot off it using the command line bootkernel root/dev/hda4 (where
bootkernel is the name of the boot section in lilo.conf - probably linux).
Once you're booted and logged in, run lilo -v -v -v -v and see if there's
anything obvious in the output.

> Dop> (I usually use lilo -r rather than chroot, btw).
>
> Okay, I can try that.  Some doc I have suggested that chroot was more
> reliable without saying why.

Not sure why, they're effectively the same thing.

> Okay. The PII CPU and (so far) HD controller have been fine with
> vanilla Linux but the sound and video chips on the board (i810) have
> been a nuisance.  I used tomsrbt (sp?) as the rescue boot floppy but I
> have an alternative here somewhere.  Annnnd...

I'd recommend using the lilo and kernel installed on your machine,
otherwise you'll be dependent on a boot disk whenever you update your
system.

I've had i810 audio and video working fine before now, it just takes a
kernel recompile.

> Thanks for the pointers.  Further suggestions welcome.

My final suggestion would be to copy the data off the drive that you want
to keep, and just reinstall from CD. Due to the somewhat convoluted
history of the boot sector, sometimes that's all you can do - starting at
fdisking the drive and deleting and recreating the partitions. Doing this
may save you more time than dinking around with BIOS settings in the long
run, too...

Cheers... Dop.




More information about the nSLUG mailing list