[nSLUG] Boot problem

Mike Spencer mspencer at tallships.ca
Wed Jan 28 16:02:21 AST 2004


me> So I removed the [new Slak-8 install] HD from the P133 and put it
me> into a PII (replacing another HD as hda).  Nothing I know how to
me> do will get it to boot in the PII.

Dop> The P133 is using a different addressing scheme from the PII, and
Dop> the PII may be hitting the 512MB limit. Can you put a /boot
Dop> partition on the drive somewhere before the 512MB limit?

"Different addressing scheme", huh?  I better use that as a key phrase
for further reading because I don't know about that.

But considering that the PII is the newest machine I have, both HDs are
formatted as you suggest:

         had1   linux swap  (128M?  I forget)
         hda2   /boot       (small)
         hda3   DOS16       (small)
         hda4   /           (remaining space)

Dop> That may be enough to get it working (specially since you're using
Dop> -l).

Well, lilo worked on the P133 *without* -l or "linear" in lilo.conf.
I tried -l from a floppy boot in response to the lilo error message.

Dop> (I usually use lilo -r rather than chroot, btw).

Okay, I can try that.  Some doc I have suggested that chroot was more
reliable without saying why.

Dop> Regardless, you'll probably have to boot off a rescue disk and
Dop> re-lilo.

Did that without success, but...

dteed> An off hand idea, but if the PII machine's chipset is somehow
dteed> not well supported by the kernel on your rescue CD, it might be
dteed> giving you problems.  Try an alternate rescue CD.

Okay. The PII CPU and (so far) HD controller have been fine with
vanilla Linux but the sound and video chips on the board (i810) have
been a nuisance.  I used tomsrbt (sp?) as the rescue boot floppy but I
have an alternative here somewhere.  Annnnd...

dteed> Gentoo makes a decent Live CD these days with plenty o' tools.

That might be even better.  Someone recently gave me what purports to
be a bootable Knoppix CD.  Maybe that would give me the same
access/tools. 

dteed> Also, try explicitly listing lba32 in the lilo.conf if you didn't
dteed> already do that.

What does that do?  Where do I look?  Not mentioned in lilo docs,
can't find it grepping through the kernel source.  That was suggested
in a lilo error message but I couldn't find explanation or syntax.


Thanks for the pointers.  Further suggestions welcome.  

Gave up beating my head against the wall at 5:00 AM last night and I'm
not going to tear the boxen apart all over my kitchen table again for
a couple of days.  (I have all sorts of neat hardware to try once this
2.4 kernel is up an running.)

Grabbing at straws,
- Mike

-- 
Michael Spencer                  Nova Scotia, Canada       .~. 
                                                           /V\ 
mspencer at tallships.ca                                     /( )\
http://home.tallships.ca/mspencer/                        ^^-^^

-- 






More information about the nSLUG mailing list